On 21 August 2014 13:27, Anne van Kesteren <ann...@annevk.nl> wrote: > On Thu, Aug 21, 2014 at 11:02 AM, Jake Archibald <jaffathec...@gmail.com> > wrote: > > * The as* methods should be directly on the response, and named > consumeAs*, > > so response.consumeAsJSON() > > Would it be really bad to have these names four characters longer to > indicate they are about the body of the response? Then we'd have: > > consumeBodyAsJSON() > consumeBodyAsText() >
Worried we're making common functions really long here, like querySelectorAll. Going from response.body.asJSON() to response.consumeAsJSON() wasn't *too* bad, but response.consumeBodyAsJSON() is getting a bit proxyfactorybeangenerator. > > and > > canConsumeBody > This isn't too bad.