interface IteratorProvider{
int size();
Iterator iterator(int start, int minCount);
IModel model(Object o); <== do you like that?
}
Shall we rename dataview to iteratorview?
I was thinking about the name again. (Good names are very important for
new users and for CVS;-))
What's about CollectionView? It would show that it is a more general
Component than ListView and any List (or other Collection) can be used as
with ListView. Accordingly the model interface should be called
CollectionProvider.
Do you think the Object of the IModel object should only be a DataProvider
or could it also be a Collection and the wrapping is done automatically by
the component so that it is a full ListView replacement?
I think in the second case the IModel model(Object ob) method should not
belong into the Provider interface because it restricts the reuse of
DefaultProviders and it is in there for convinience only.
Anyway additonal comments would indeed help a lot.
I am hoping tomorrow I will have enough time to create a project for
this in
wicket-stuff and check it in.
Very good looking forward please let me know.
I removed them (moveUp() and moveDown()) from dataview as I also do not
have any need, and ordering
doesn't really make sense with iterators.
A very wise decision and it should keep this way.
Christian
___________________________________________________________
Gesendet von Yahoo! Mail - Jetzt mit 1GB Speicher kostenlos - Hier anmelden: http://mail.yahoo.de
-------------------------------------------------------
SF.Net email is Sponsored by the Better Software Conference & EXPO September
19-22, 2005 * San Francisco, CA * Development Lifecycle Practices
Agile & Plan-Driven Development * Managing Projects & Teams * Testing & QA
Security * Process Improvement & Measurement * http://www.sqe.com/bsce5sf
_______________________________________________
Wicket-user mailing list
[email protected]
https://lists.sourceforge.net/lists/listinfo/wicket-user