And you example works perfectly if you rename wicket:id="message" to wicket:id="myMessage"?
Juergen On 4/15/06, Juergen Donnerstag <[EMAIL PROTECTED]> wrote: > Would you please create a junit test case (see src/test) to reproduce it. > Thanks > > Juergen > > On 4/15/06, Michael Day <[EMAIL PROTECTED]> wrote: > > In my markup, I have added a RequiredTextField component called > > "message". I also use the <wicket:message> tag. Wicket seems to get > > them confused. Is this a bug? > > > > wicket.markup.MarkupException: Component message must be applied to a > > tag of type 'input', not '<wicket:message key="phone">' (line 0, > > column 0) > > > > > > ------------------------------------------------------- > > This SF.Net email is sponsored by xPML, a groundbreaking scripting language > > that extends applications into web and mobile media. Attend the live webcast > > and join the prime developer group breaking into this new coding territory! > > http://sel.as-us.falkag.net/sel?cmd=lnk&kid=110944&bid=241720&dat=121642 > > _______________________________________________ > > Wicket-user mailing list > > [email protected] > > https://lists.sourceforge.net/lists/listinfo/wicket-user > > > ------------------------------------------------------- This SF.Net email is sponsored by xPML, a groundbreaking scripting language that extends applications into web and mobile media. Attend the live webcast and join the prime developer group breaking into this new coding territory! http://sel.as-us.falkag.net/sel?cmd=lnk&kid0944&bid$1720&dat1642 _______________________________________________ Wicket-user mailing list [email protected] https://lists.sourceforge.net/lists/listinfo/wicket-user
