Hi All,

I have an ajax problem on Safari browser. When I update a component  
using AbstractDefaultAjaxBehavior the ajax log
looks like following:

-- begin --
INFO:
INFO: Initiating Ajax GET request on /quickstart/app? 
wicket:interface=: 
1:tooltip2Trigger:tooltip2Border::IBehaviorListener&wicket:behaviorId=0& 
random=0.4174859744578069
INFO: Invoking pre-call handler(s)...
INFO: Received ajax response (686 characters)
INFO:
<?xml version="1.0" encoding="UTF-8"?><ajax-response><component  
id="tooltip2Trigger_tooltip2Border"  encoding="wicket1" ><![CDATA 
[<span style="display:none;" id="tooltip2Trigger_tooltip2Border"  
wicket:id="tooltip2Border" class="tooltip"><wicket:border><wicket:body>
                     This is a static tooltip loaded on first  
mouseover event!
                 </wicket:body></wicket:border></span><script  
type="text/javascript" ><!--/*--><![CDATA[/*><!--*/
tooltipManager.registerTrigger('tooltip2Trigger',  
'tooltip2Trigger_tooltip2Border', false, '/quickstart/app? 
wicket:interface=: 
1:tooltip2Trigger:tooltip2Border::IBehaviorListener&wicket:behaviorId=0' 
);

/*-->]^]^>*/</script>

]]></component></ajax-response>
INFO: Response parsed. Now invoking steps...
-- end --

It looks like the response cannot be processed correctly and  
javascript 'hangs' because on every following request I get the  
'Chanel busy - postponing...' message.

On Firefox everything works fine. To compare following is the ajax log:

-- begin--
INFO:
INFO: Initiating Ajax GET request on /quickstart/app? 
wicket:interface=: 
2:tooltip2Trigger:tooltip2Border::IBehaviorListener&wicket:behaviorId=0& 
random=0.9799105785595497
INFO: Invoking pre-call handler(s)...
INFO: Received ajax response (686 characters)
INFO:
<?xml version="1.0" encoding="UTF-8"?><ajax-response><component  
id="tooltip2Trigger_tooltip2Border"  encoding="wicket1" ><![CDATA 
[<span style="display:none;" id="tooltip2Trigger_tooltip2Border"  
wicket:id="tooltip2Border" class="tooltip"><wicket:border><wicket:body>
                     This is a static tooltip loaded on first  
mouseover event!
                 </wicket:body></wicket:border></span><script  
type="text/javascript" ><!--/*--><![CDATA[/*><!--*/
tooltipManager.registerTrigger('tooltip2Trigger',  
'tooltip2Trigger_tooltip2Border', false, '/quickstart/app? 
wicket:interface=: 
2:tooltip2Trigger:tooltip2Border::IBehaviorListener&wicket:behaviorId=0' 
);

/*-->]^]^>*/</script>

]]></component></ajax-response>
INFO: Response parsed. Now invoking steps...
INFO: Response processed successfully.
INFO: Invoking post-call handler(s)...
-- end --

Any idea what could be wrong with this response?

Regards,
Adam






-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job easier
Download IBM WebSphere Application Server v.1.0.1 based on Apache Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
Wicket-user mailing list
Wicket-user@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/wicket-user

Reply via email to