Review: Approve
> DO NOT TEST THIS BRANCH!
Not sure how you want to handle the merge for this. Do you want to have all
branches reviewed and then merge only the last one?
[PlayerSlot and other using = int decls]
I am not a fan of this. An integer is an integer, the variable name should make
it clear what it means. If you want type_safty (not accidentally use a
PlayerSlot as a pixel length for example), introduce a struct PlayerSlot { int
slot; }.
Something for another branch though probably.
Otherwise LGTM. I compiled and reviewed code, I did not test this branch.
What should I look at next?
--
https://code.launchpad.net/~widelands-dev/widelands/multiplayer_dropdowns_1_type/+merge/326304
Your team Widelands Developers is subscribed to branch
lp:~widelands-dev/widelands/multiplayer_dropdowns_1_type.
_______________________________________________
Mailing list: https://launchpad.net/~widelands-dev
Post to : [email protected]
Unsubscribe : https://launchpad.net/~widelands-dev
More help : https://help.launchpad.net/ListHelp