In a terminal:

cd $WIENROOT
./siteconfig
C
ifort
cc
enter
R
A

The default C compiler in the fifth step above should be cc (or gcc). Did you enter cc (or gcc) for the compiler and then recompile (A in the eighth step to compile all programs)?

If you are trying to use icc instead of cc, then you might need to check what your system processors are and specify the processor-specific options for it. For example, if you are using the Intel C++ (icc) Compiler 16.0, the User and Reference Guide for it on the Intel website should be at:

https://software.intel.com/en-us/node/581749

In addition to documentation on the Intel website, you can also likely find the documentation for your specific icc version in folders at the location where you installed the Intel compiler on your system, which is usually something like:

/opt/intel/composerxe/Documentation/

So instead of entering

icc

you could try one of the options that should target a processor without the AVX2, so you could try entering for example:

icc -xSSE4.2

On 6/9/2016 7:30 PM, halim said wrote:
Dear Professor Peter,

Thank you for the clarification, I did let it as default, I did not change it and still the same error occur.




Le Jeudi 9 juin 2016 15h18, Peter Blaha <pbl...@theochem.tuwien.ac.at> a écrit :


sgroup is a C-program. Thus it has nothing to do with the
ifort-conmpiler options, but with your C-compiler.

Did you use icc or just cc ?? It is probably best to leave it as set in
the default.



Am 06.06.2016 um 04:50 schrieb Gavin Abo:
> The Intel compiler probably was not able to detect the processor(s) that
> your system uses, such that it generated an executable using instruction
> sets that are wrong for your system.  The Haswell and Broadwell
> processors use Advanced Vector Extensions 2 (AVX2) instructions [
> http://www.nas.nasa.gov/hecc/support/kb/recommended-compiler-options_99.html
> ], but from your error message, it seems that you likely have a
> processor like the Sandy Bridge or Ivy Bridge that does not support the
> AVX2 instruction set.
>
> So, you will probably have to specify manually what the
> processor-specific options should be for your system.  Refer to the
> Intel documentation for the version of the Intel compiler that you are
> using to determine the processor-specific options. For example, if you
> are using Intel Fortran Compiler 16.0, the User and Reference Guide for
> it on the Intel website should be at:
>
> https://software.intel.com/en-us/node/579311
>
> On 6/5/2016 2:14 PM, halim said wrote:
>> Dear Wien2k users,
>>
>> When installing wien2k at cray system with the following bellow:
>>
>>  I would like to ask you for linking my software using  intelfortran
>> and mkl:
>>
>> O  Compiler options:        -FR -mp1 -w -prec_div -pc80 -pad -ip
>> -DINTEL_VML -traceback
>>
>>
>> R  R_LIB (LAPACK+BLAS):    -lmkl_lapack95_lp64 -lmkl_intel_lp64
>> -lmkl_intel_thread -lmkl_core -openmp -lpthread
>>
>>
>>
>> But when I tried init_lapw :
>>
>> with x nn it is fine
>>
>> when typing
>> x sgroup
>>
>> I got this error: Please verify that both the operating system and the
>> processor support Intel(R) MOVBE, FMA, BMI, LZCNT and AVX2 instructions
>>
>> what is the origine of this error?
>>
>>
>>
>> Looking forward for your answer.
>>
>> Halim Said
>> Univ Hail, SA
>
>
> _______________________________________________
> Wien mailing list
> Wien@zeus.theochem.tuwien.ac.at <mailto:Wien@zeus.theochem.tuwien.ac.at>
> http://zeus.theochem.tuwien.ac.at/mailman/listinfo/wien
> SEARCH the MAILING-LIST at: http://www.mail-archive.com/wien@zeus.theochem.tuwien.ac.at/index.html
>

--
--------------------------------------------------------------------------
Peter BLAHA, Inst.f. Materials Chemistry, TU Vienna, A-1060 Vienna
Phone: +43-1-58801-165300            FAX: +43-1-58801-165982
Email: bl...@theochem.tuwien.ac.at <mailto:bl...@theochem.tuwien.ac.at> WIEN2k: http://www.wien2k.at <http://www.wien2k.at/>
WWW: http://www.imc.tuwien.ac.at/staff/tc_group_e.php

--------------------------------------------------------------------------
_______________________________________________
Wien mailing list
Wien@zeus.theochem.tuwien.ac.at
http://zeus.theochem.tuwien.ac.at/mailman/listinfo/wien
SEARCH the MAILING-LIST at:  
http://www.mail-archive.com/wien@zeus.theochem.tuwien.ac.at/index.html

Reply via email to