Dear wien2wannier developer

I am a novice wien2k user. I am running wien2k version 14.2 compiled with
intel compilers on machine with Centos operating system. I am trying to use
wien2wannier interface to get MLWF. I have been struggling with a strange
bug. I know this bug has been floating around for a while.I would really
appreciate your input.
So, here is my problem:

The crystal I am working is Zr2Te2P which has rhombohedral lattice
structure and has inversion symmetry. First I performed spin polarized with
spin orbit coupling DFT calculation and as per the direction in the manual
of w2w, I performed following steps:

     ->prepare_w2wdir dft_dir wannier_dir

    ->cd wannier_dir ; then init_w2w

    -> x lapw1 -up -p ; x lapw1 -dn -p

    -> x lapwso -up -p

     -> x w2w -up -so -p

In this step, I get error like:

*forrtl: severe (39): error during read, unit 9, file wannier.vectorsoup_1*

and similar error for the down spin.

Strangely, I did not get this error for bcc iron when I was trying to
reproduce the example 18 result in the Wannier90 manual.

However I tried the similar thing for BaTiO3 crystal (by using the struct
file given in the lambda0 directory of BerryPi package) . And, I got the
same error. I wonder if this error occurs only for crystals with certain

The strange thing is w2w works fine without spin orbit coupling for all of
the above crystals.

I would really appreciate you feedback. Thank you!

With regards

Niraj Aryal
Grad. Student
Florida State University
Tallahassee, Florida-32304
Wien mailing list

Reply via email to