I will continue tomorrow,
dann sitz ich direkt am Linux Rechner und da erzeugen die '  auch keine 
merkwürdigen Zeichen

Ciao
Gerhard

DEEP THOUGHT in D. Adams; Hitchhikers Guide to the Galaxy:
"I think the problem, to be quite honest with you,
is that you have never actually known what the question is."

====================================
Dr. Gerhard H. Fecher
Institut of Inorganic and Analytical Chemistry
Johannes Gutenberg - University
55099 Mainz
and
Max Planck Institute for Chemical Physics of Solids
01187 Dresden
________________________________________
Von: Wien [wien-boun...@zeus.theochem.tuwien.ac.at] im Auftrag von Elias 
Assmann [elias.assm...@gmail.com]
Gesendet: Mittwoch, 21. Dezember 2016 16:06
An: A Mailing list for WIEN2k users
Betreff: Re: [Wien] w2w compilation problem during siteconfig

On 12/21/2016 03:01 PM, Fecher, Gerhard wrote:
> Here it is,

Thank you.

> Don't ask me why the output is partially in Austrian ;-)

Yeah, up to the inwards-looking guillemets.  “Macht nichts” is endearing.

> make --version gives:
> GNU Make 3.82
> Built for x86_64-unknown-linux-gnu
> Copyright (C) 2010  Free Software Foundation, Inc.

Well, it is old, but it is GNU make and not that old -- I doubt that is
an issue.

> Betrachte Target-Datei »lib/util_w2w.o«.
>  Die Datei »lib/util_w2w.o« existiert nicht.
>  Suche nach einer impliziten Regel für »lib/util_w2w.o«.
>  Versuche Muster-Regel mit Ersetzung »util_w2w«.
>  Versuche implizite Voraussetzung »util_w2w.[fF]«.

There seems to be a difference here:

Considering target file 'lib/util_w2w.o'.
 File 'lib/util_w2w.o' does not exist.
 Looking for an implicit rule for 'lib/util_w2w.o'.
 Trying pattern rule with stem 'util_w2w'.
 Trying implicit prerequisite 'util_w2w.F'.

You can see that my make gives me straight '' quotes even though I have
a UTF-8 locale set.  No, that's not it …

It looks like your make does not recognize the [fF] glob.  Why this
should be, I do not understand.  I found a machine (VSC-3) that is also
running GNU make 3.82, and it does not seem to have this problem.

If you want to build wien2wannier, or just get rid of the compilation
errors, or want to help me fix this problem, you could try splitting the
rule

> $(O_DIR)/%.o: %.[fF] Makefile
>         @test -d $(O_DIR) || mkdir $(O_DIR)
>         $(FC) $(FFLAGS) -c $< -o$@ $(MODOPT) $(O_DIR)

into one duplicate for %.f and one %.F:

$(O_DIR)/%.o: %.f Makefile
        @test -d $(O_DIR) || mkdir $(O_DIR)
        $(FC) $(FFLAGS) -c $< -o$@ $(MODOPT) $(O_DIR)

$(O_DIR)/%.o: %.F Makefile
        @test -d $(O_DIR) || mkdir $(O_DIR)
        $(FC) $(FFLAGS) -c $< -o$@ $(MODOPT) $(O_DIR)


        Elias

--
Elias Assmann
Institute of Theoretical and Computational Physics
TU Graz                   <https://itp.tugraz.at/>

_______________________________________________
Wien mailing list
Wien@zeus.theochem.tuwien.ac.at
http://zeus.theochem.tuwien.ac.at/mailman/listinfo/wien
SEARCH the MAILING-LIST at:  
http://www.mail-archive.com/wien@zeus.theochem.tuwien.ac.at/index.html

Reply via email to