In addition to what Fabien Tran said:

If you expand the density/potential up to l=10, it makes only sense if you also increase the LVNSmax value in case.in1 from 4 to 6 (or 8), otherwise these potential components will not even be used in the calculations.


Please remember in general: when you have LARGE SPHERES (gt.~2.2) and large nonsphericity, an increase of this value could be very important for "highest" precision. The effect can in some cases be "larger" than increasing RKmax from 8 to 10 !!

For these reasons, init_lapw gives you now a "warning" or a "hint" about this, when it detects large spheres. Take it seriously when aiming for highest accuracy. To be able to make this automatically, there is a new parameter for init_lapw in batch mode: -lvns X

Peter Blaha

On 09/13/2017 10:10 AM, t...@theochem.tuwien.ac.at wrote:
Hi,

Maybe it's because you are using lmax=10 in case.in2.
Does the problem persist if you use the default lmax=6 in case.in2?
Anyway, lmax=6 is already a very good value, so why are you using
lmax=10?

FT

On Wednesday 2017-09-13 10:02, Jiawei Zhang wrote:

Date: Wed, 13 Sep 2017 10:02:46
From: Jiawei Zhang <jiaweizh...@chem.au.dk>
Reply-To: A Mailing list for WIEN2k users
<wien@zeus.theochem.tuwien.ac.at>
To: "Wien@zeus.theochem.tuwien.ac.at" <Wien@zeus.theochem.tuwien.ac.at>
Subject: [Wien] Error related to nlvdw calculations

Dear WIEN2k developers and users,
I am trying to do a calculation on some layered materials by including
the nlvdw correction into SCF calculation in Wien2k 17.1 running at
Linux system (Intel
E5-2680, CentOS 7 Linux 64 bit) with intel compilers. The calculations
are successful without the calculation of the potential; however, I
always get errors when
I switch on the potential calculations. In the beginning, when I set
"calculation of the potential (T or F)" to "T" in case.innlvdw, I
always get the error
“Insufficient virtual memory”. According to the suggestion from the
previous post, in the line 41 in SRC_nlvdw/calc_vvdw.F, add : lmtmp =0
and recompile a
selected package : nlvdw. The error “Insufficient virtual memory” is
solved. But then I always get the following errors:
In case.dayfile,    start (Wed Sep 13 00:35:04 CEST 2017) with nlvdw
(200/99 to go)
  nlvdw  > & /dev/null (00:35:04)
  nlvdw (00:36:17) 82.380u 0.204s 1:22.67 99.8% 0+0k 22384+1424io 3pf+0w
    cycle 1 (Wed Sep 13 00:37:40 CEST 2017) (200/99 to go)
  lapw0 -nlvdw (00:37:40) 0.925u 0.063s 0:01.06 92.4% 0+0k 6432+56io
8pf+0w
error: command   /home/jiawei/src/WIEN2k_17.1/lapw0 lapw0.def   failed
  stop error
Error details:
NLVDW END
forrtl: severe (64): input conversion error, unit 66, file /home
/work/WIEN2k/WIEN2k_17.1/SnSe/exp/PBE_rVV10/include_potential/SnSe/SnSe.r2v_nlvdw

Image              PC                Routine            Line
 Source
lapw0              000000000051E423  Unknown               Unknown
 Unknown
lapw0              000000000054F798  Unknown               Unknown
 Unknown
lapw0              000000000054C7EA  Unknown               Unknown
 Unknown
lapw0              00000000004444C5  MAIN__                   2102
 lapw0.F
lapw0              00000000004054AE  Unknown               Unknown
 Unknown
libc.so.6          00000039B041ECDD  Unknown               Unknown
 Unknown
lapw0              00000000004053B9  Unknown               Unknown
 Unknown

For the calculations, I set kpoints=605, RKmax=10, and expand lmax to
10 in case.in2.
I have tried running in both single mode or parallel mode and I get
the same error. Does anyone have any suggestion on how to fix the
problem. Thanks in advance!
Best regards,
Jiawei​






​


_______________________________________________
Wien mailing list
Wien@zeus.theochem.tuwien.ac.at
http://zeus.theochem.tuwien.ac.at/mailman/listinfo/wien
SEARCH the MAILING-LIST at:  
http://www.mail-archive.com/wien@zeus.theochem.tuwien.ac.at/index.html


--

                                      P.Blaha
--------------------------------------------------------------------------
Peter BLAHA, Inst.f. Materials Chemistry, TU Vienna, A-1060 Vienna
Phone: +43-1-58801-165300             FAX: +43-1-58801-165982
Email: bl...@theochem.tuwien.ac.at    WIEN2k: http://www.wien2k.at
WWW:   http://www.imc.tuwien.ac.at/TC_Blaha
--------------------------------------------------------------------------
_______________________________________________
Wien mailing list
Wien@zeus.theochem.tuwien.ac.at
http://zeus.theochem.tuwien.ac.at/mailman/listinfo/wien
SEARCH the MAILING-LIST at:  
http://www.mail-archive.com/wien@zeus.theochem.tuwien.ac.at/index.html

Reply via email to