Probably the error "sed: Command not found" should not be ignored.  Do you have sed installed?

The command to install it can vary such as between Debian based (sudo apt install sed) and RPM based systems (yum install sed) [1].  So check the documentation for your Linux distribution for how to install it.

The "filename: /case.vector" might also provide a clue at what might be wrong.  It is usually problematic for files to be at the root (/) path.  Though as mentioned previously [2], that might not be a problem for hf. However, "case.vector" is likely for a non-hf non-parallel calculation (run_lapw) when the program likely should be looking for a "case.vectorhf_$i" file for your hf parallel calculation (run_lapw -hf -p).

Adding the verbose switch to your script(s), such as x_lapw and/or lapw2para_lapw, might help you isolate where the problem is occurring [3,4].

[1] https://www.tutorialspoint.com/sed/sed_environment.htm
[2] https://www.mail-archive.com/wien@zeus.theochem.tuwien.ac.at/msg19229.html [3] https://www.mail-archive.com/wien@zeus.theochem.tuwien.ac.at/msg17973.html [4] https://www.mail-archive.com/wien@zeus.theochem.tuwien.ac.at/msg15011.html

On 11/25/2019 9:36 AM, Peeyush kumar kamlesh wrote:
Hello Wien2k user,
Greetings!
I am running scf cycle with hf potential. When I run the command "run_lapw -hf -p", then after successful completion of 7 cycles, I found error in cycle 8. In terminal it is represented as follows:
____________________________________________________
in cycle 8    ETEST: .0004919150000000   CTEST: .0035867
hup: Command not found.
 LAPW0 END
 LAPW0 END
 LAPW1 END
 LAPW1 END
 LAPW1 END
 LAPW1 END
sed: Command not found.
LAPW2 - Error. Check file lapw2.error
cp: cannot stat '.in.tmp': No such file or directory

>   stop error
------------------------------------------------------------------------------

When I checked lapw2.error file I found following details:
_____________________________________________________
'LAPW2' - can't open unit: 10
 'LAPW2' - filename: /case.vector
 'LAPW2' -          status: unknown      form: unformatted
**  testerror: Error in Parallel LAPW2
---------------------------------------------------------------------------------------

I also tried to search and understand the previous threads, but I was unable to do so. Kindly suggest me why this error is appearing and how can it be resolved?

Thanks and Regards
Peeyush Kumar Kamlesh
_______________________________________________
Wien mailing list
Wien@zeus.theochem.tuwien.ac.at
http://zeus.theochem.tuwien.ac.at/mailman/listinfo/wien
SEARCH the MAILING-LIST at:  
http://www.mail-archive.com/wien@zeus.theochem.tuwien.ac.at/index.html

Reply via email to