https://bugzilla.wikimedia.org/show_bug.cgi?id=57394

C. Scott Ananian <canan...@wikimedia.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |canan...@wikimedia.org

--- Comment #7 from C. Scott Ananian <canan...@wikimedia.org> ---
I suggest we first do a refactor to use uniformly use:
  DU.data(node)
for getters, and maybe
  DU.data(node, new_data)
for setters?

Then we can easily experiment with/bikeshed different implementations of
DU.data() under the hood -- first probably using a new 'parsoid-data' or
'dataobject' attribute, then later benchmarking against using an external map
keyed on id, or an es6 weak map, or an es6 private field, etc.

-- 
You are receiving this mail because:
You are on the CC list for the bug.
_______________________________________________
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l

Reply via email to