https://bugzilla.wikimedia.org/show_bug.cgi?id=22179

           Summary: Internal use of API (FauxRequest) results in HTTP
                    headers being set
           Product: MediaWiki
           Version: 1.15.1
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: major
          Priority: Normal
         Component: API
        AssignedTo: roan.katt...@gmail.com
        ReportedBy: open...@gmail.com
                CC: bryan.tongm...@gmail.com, s...@reedyboy.net,
                    vasi...@gmail.com, soxre...@gmail.com


Discussion can be found here:
http://toolserver.org/~mwbot/logs/%23mediawiki/20100119.txt (search for
"openbip")

I'm creating new tags using the MediaWiki API internally
(http://www.mediawiki.org/wiki/API:Calling_internally) via FauxRequest.

Some of these tags create new wiki pages automatically.  When save (or preview)
a page with one of these tags, instead of seeing the updated page (or the
preview of the updated page), my browser redirects to one of the newly-created
pages.

Thus, it seems that using the MediaWiki API, even internally, results in HTTP
headers being set.

-- 
Configure bugmail: https://bugzilla.wikimedia.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.

_______________________________________________
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l

Reply via email to