https://bugzilla.wikimedia.org/show_bug.cgi?id=59676

       Web browser: ---
            Bug ID: 59676
           Summary: wbgetentities not working with multiple sites
           Product: MediaWiki extensions
           Version: master
          Hardware: All
                OS: All
            Status: NEW
          Severity: normal
          Priority: Unprioritized
         Component: WikidataRepo
          Assignee: wikidata-b...@lists.wikimedia.org
          Reporter: wikimushr...@gmail.com
                CC: wikidata-b...@lists.wikimedia.org
    Classification: Unclassified
   Mobile Platform: ---

According to the API documentation, wbgetentities should accept requests with:
• one site for several titles, or
• several sites for one title.

However, patch 80797 changed the code to only allow:
• one site and several titles, or
• equal numbers of sites and titles.

(see here: https://gerrit.wikimedia.org/r/#/c/80797/)

So this request works fine:
https://www.wikidata.org/w/api.php?action=wbgetentities&sites=enwiki|itwiki&titles=London|Berlin

But this one returns an error:
https://www.wikidata.org/w/api.php?action=wbgetentities&sites=enwiki|itwiki&titles=London

It doesn't make sense, the older behavior should be restored.

-- 
You are receiving this mail because:
You are on the CC list for the bug.
_______________________________________________
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l

Reply via email to