https://bugzilla.wikimedia.org/show_bug.cgi?id=21907

--- Comment #12 from Chad H. <innocentkil...@gmail.com> 2010-01-26 23:18:02 UTC 
---
Ok, there seem to be two bugs being discussed here at once. Let me try to make
sense of it all.

(In reply to comment #0)
> "Detected bug in an extension! Hook FCKEditor_MediaWiki::onCustomEditor failed
> to return a value; should return true to continue hook processing or false to
> abort".

As I said in comment #2, this bug happens when a hook function (in this case:
FCKEditor_MediaWiki::onCustomEditor using the CustomEditor hook) fails to
return a boolean to continue or halt further processing. I have checked both
trunk and the REL1_15 branch (as of r61540) and the onCustomEditor method seems
to be returning false, as it should. Can you please check your copy for this?
If it's not returning false, try returning false and see if that fixes it.

(In reply to comment #8)
> In FCKeditor.body.php the custom editor function is defined as:
> 
>   public function onCustomEditor(&$article, &$user)
> 
> 
> But in Wiki.php, there is a line that says:
> 
>   if( wfRunHooks( 'CustomEditor', array( $article, $user ) ) ) {
> 

The hook is correct and the extension is wrong. Neither $article or $user
should be passed by reference. This was fixed in trunk in r50690. This portion
of the bug is FIXED.

-- 
Configure bugmail: https://bugzilla.wikimedia.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
You are watching all bug changes.

_______________________________________________
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l

Reply via email to