https://bugzilla.wikimedia.org/show_bug.cgi?id=60207

       Web browser: ---
            Bug ID: 60207
           Summary: expandTemplate doesn’t create a new frame
           Product: MediaWiki extensions
           Version: unspecified
          Hardware: All
               URL: https://test2.wikipedia.org/wiki/Multiple_transclusion
                OS: All
            Status: NEW
          Severity: normal
          Priority: Unprioritized
         Component: Scribunto
          Assignee: wikibugs-l@lists.wikimedia.org
          Reporter: seb35wikipe...@gmail.com
                CC: bjor...@wikimedia.org, tstarl...@wikimedia.org,
                    vasi...@gmail.com
    Classification: Unclassified
   Mobile Platform: ---

When a Lua module uses the function frame:expandTemplate, this doesn’t create a
new frame (contrary to frame:preprocess) but expand the template in the "top"
frame (the parent frame of the expanded template is the top frame).

I guess this is a bug since the "parent frame" is defined as the "the frame for
the page that called {{#invoke:}}" ([[mw:Extension:Scribunto/Lua reference
manual#frame:getParent]]).

I created some pages to illustrate this behaviour on
https://test2.wikipedia.org/wiki/Multiple_transclusion. It can be remarked also
that if you again transclude the "Multiple transclusion" page, the first case
shows the new top frame.

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
_______________________________________________
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l

Reply via email to