Web browser: ---
            Bug ID: 60384
           Summary: hhvm not working
           Product: MediaWiki-Vagrant
           Version: unspecified
          Hardware: All
                OS: All
            Status: NEW
          Severity: normal
          Priority: Unprioritized
         Component: General
    Classification: Unclassified
   Mobile Platform: ---

I enabled the hhvm role and ran `vagrant provision`.  I had a problem with
hhvm's libmemcached6 conflicting with my outdated php5-memcached's
libmemcached10, but `sudo apt-get install php5-memcached` fixed that and then
`vagrant provision` worked. I have a /usr/bin/hhvm binary that runs.

However, my Special:Version says "PHP  5.3.10-1ubuntu3.9 (fpm-fcgi)".

I've tried:
* `sudo apachectl restart`, ps shows "/usr/sbin/apache2 -D HHVM -k start"

* I noticed I have a number of "php-fpm: pool www" processes. I did `sudo
service php5-fpm stop` and restarted apache again, and then apache error log
failed with
 [Thu Jan 23 23:08:48 2014] [error] [client] (111)Connection refused:
FastCGI: failed to connect to server "/usr/lib/cgi-bin/php5-hhvm":
 I have no such file.

* `vagrant reload` didn't help

* I tried `sudo /etc/init.d/hhvm start` , /vagrant/logs/hhvm-error.log
  Unable to read pid file /var/run/hhvm/pid for any meaningful pid
  Unable to start page server
  Shutting down due to failure(s) to bind in HttpServer::run

I'm not sure what's going on.

You are receiving this mail because:
You are on the CC list for the bug.
Wikibugs-l mailing list

Reply via email to