https://bugzilla.wikimedia.org/show_bug.cgi?id=60842

       Web browser: ---
            Bug ID: 60842
           Summary: VisualEditor not available on some wikis where
                    expected due to load.php config issue
           Product: VisualEditor
           Version: unspecified
          Hardware: All
                OS: All
            Status: NEW
          Severity: normal
          Priority: Unprioritized
         Component: General
          Assignee: jforres...@wikimedia.org
          Reporter: jh...@wikimedia.org
                CC: jforres...@wikimedia.org, jh...@wikimedia.org,
                    krinklem...@gmail.com, ryasm...@wikimedia.org
    Classification: Unclassified
   Mobile Platform: ---

While developing a browser test for bug 60797, I've noticed that some
production wikis where VisualEditor is expected to be available do not load VE
as expected.  In each case, the error message captured at the browser level is
(with some variation in the specific line numbers referenced):


[Error] Error: JavaScript parse error: Parse error: Missing operand in file
'MediaWiki:Common.js' on line 125
    global code (load.php, line 1)



Repro steps:

1) Visit a production wiki where VE is expected to be available, and request a
random article with a VE edit param:
http://cv.wikipedia.org/wiki/Special:Random?veaction=edit

2) In browser error console, note JavaScript error mentioned above, and note
also that the VE editing surface simply never loads (although it appears to
keep trying!)


I'll add list(s) of production wikis where this problem occurs as I uncover
them in comments on this bug ticket.

-- 
You are receiving this mail because:
You are on the CC list for the bug.
_______________________________________________
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l

Reply via email to