https://bugzilla.wikimedia.org/show_bug.cgi?id=60899

       Web browser: ---
            Bug ID: 60899
           Summary: VisualEditor: template and link inspectors not working
                    for some users at it.wp
           Product: VisualEditor
           Version: unspecified
          Hardware: All
                OS: All
            Status: NEW
          Severity: normal
          Priority: Unprioritized
         Component: General
          Assignee: jforres...@wikimedia.org
          Reporter: elitr...@gmail.com
                CC: jforres...@wikimedia.org, jh...@wikimedia.org,
                    krinklem...@gmail.com, ryasm...@wikimedia.org
    Classification: Unclassified
   Mobile Platform: ---

Might need to split this later, and/or add more details, here's what we know
now from it.wp users.

Not logged in user, Firefox 26.0, Windows 7 reports the following.
*When you try to edit a template, the template inspector will look empty.
*When you try to add a new template, the inspector won't provide any
suggestions for existing ones.
*When you try to choose an option from the 3-bars menu on the right, none will
work (nothing will happen clicking on those), except for the "Switch to
wikitext" one.

User:Nnvu, Chrome ver. 32.0.1700.102 m, Windows 8.1, Vector reports having the
same issues, plus:
*When you click on a wikilink anywhere in the page, instead than getting the
box to edit it, you'll be directed to the linked page (the page will even ask
you if you're sure you wanna leave).
*When you save the page, it will stay in edit mode. If you click Save again,
you'll get both the save dialog and the loading bar that keeps going. (The page
results correctly saved from the history, nonetheless.) 

Nnvu could check the console once, and said that this message
*event.returnValue is deprecated. Please use the standard
event.preventDefault() instead.
appeared once the editing page was loaded, while
*Uncaught TypeError: Object #<Object> has no method 'apiRequest' VM189:567
is what he got while trying to type inside the template inspector.

VE will work fine for him:
*if he logs out (but while when he's logged-in, disabling all BetaFeatures, all
the gadgets and even blanking .js pages won't still help);
*if he uses FF, as a logged-in user.

-- 
You are receiving this mail because:
You are on the CC list for the bug.
_______________________________________________
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l

Reply via email to