Summary: version attribute for html is obsolete now on html5
           Product: MediaWiki
           Version: 1.16-svn
          Platform: All
        OS/Version: All
            Status: NEW
          Keywords: need-review, patch
          Severity: normal
          Priority: Normal
         Component: Page rendering

Created an attachment (id=7154)
 --> (
remove html5version configuration option and related code.

in wgHtml5 mode with wgWellFormedXml off mediawiki outputs a version attribute
on the html tag configurable by wgHtml5Version. This causes pages to not
validate and according to w3c it is obsolete. This patch removes it.

(Unless ive missed something and there is a reason for this)?

Related: mediawiki w3c validation is currently broken. by default mediawiki
installs with wghtml5 + wgwellformedxml config options on. this outputs an
xhtml strict doctype. I have read simetricals comment on this in the source,
but for me I would like to have html5 + markup with quotes. so well formed, but
with the html5 doctype. at least it would have some chance of validating then.

Configure bugmail:
------- You are receiving this mail because: -------
You are the assignee for the bug.
You are on the CC list for the bug.

Wikibugs-l mailing list

Reply via email to