https://bugzilla.wikimedia.org/show_bug.cgi?id=62025

            Bug ID: 62025
           Summary: Fix basic selser failures in tests
           Product: Parsoid
           Version: unspecified
          Hardware: All
                OS: All
            Status: NEW
          Severity: normal
          Priority: Unprioritized
         Component: General
          Assignee: gwi...@wikimedia.org
          Reporter: gwi...@wikimedia.org
                CC: jforres...@wikimedia.org, ssas...@wikimedia.org
       Web browser: ---
   Mobile Platform: ---

From https://gerrit.wikimedia.org/r/#/c/115965/:

egrep '"selser".* 5", "' ./parserTests-blacklist.js:

add("selser", "Comment semantics: unclosed comment at end 5", "<!--This comment
will run out to the end of the document-->");
add("selser", "HTML-pre: 1. embedded newlines 5",
"<pre>foo</pre>\n\n<pre>\nfoo\n</pre>\n\n<pre>\nfoo\n</pre>\n\n<pre>\n\nfoo\n</pre>");

Subbu: Weird: debug_selser.sh script passes this test.

Looked into this a bit too, but it does fail reliably in parserTests. The diff
is a newline inside one of the pres. This does not happen in
http://parsoid.wmflabs.org/_rtselser/mediawikiwiki/User:GWicke/Test/embedded_nls
however. Some issue about non-selser wt2wt mode leaving dirty separator state
maybe?

add("selser", "Sanitizer: Closing of closed but not open table tags 5", "Table
not started");
add("selser", "References: 5. ref tags in references should be processed while
ignoring all other content 5", "A <ref name=\"a\" />\nB <ref
name=\"b\">bar</ref>\n\n<references\n\n<references>\n<ref
name=\"a\">foo</ref>\nThis should just get lost.\n</references>");

Subbu: This looks like a real bug that needs investigation and fixing.

add("selser", "Tables: 1d. No escaping needed 5", "foo");


add("selser", "RT-ed inter-element separators should be valid separators 5",
"\n{|\n|- [[foo]]\n|}");
add("selser", "2. Ensure fostered text content is wrapped in spans (traps
regressions around fostered marker on the span getting lost) 5", "\n{|\n|- ||
||\n| a\n|}");

Subbu: Extra leading newline at start of document -- seems harmless, but could
be investigated.

add("selser", "Table in fosterable position 5",
"{{OpenTable}}\n<div>\n{|\n|}\n");

-- 
You are receiving this mail because:
You are on the CC list for the bug.
_______________________________________________
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l

Reply via email to