https://bugzilla.wikimedia.org/show_bug.cgi?id=22609

           Summary: Incorrect articlepath returned for query&meta=siteinfo
           Product: MediaWiki
           Version: unspecified
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: minor
          Priority: Normal
         Component: API
        AssignedTo: roan.katt...@gmail.com
        ReportedBy: m8r-udf...@mailinator.com
                CC: bryan.tongm...@gmail.com, s...@reedyboy.net,
                    vasi...@gmail.com, soxre...@gmail.com


When querying siteinfo at
http://en.wikipedia.org/w/api.php?action=query&meta=siteinfo,

It returns

<?xml version="1.0"?>
<api>
  <query>
    <general mainpage="Main Page" base="http://en.wikipedia.org/wiki/Main_Page";
sitename="Wikipedia" generator="MediaWiki 1.16alpha-wmf"
phpversion="5.2.4-2ubuntu5.7wm1" phpsapi="apache2handler" dbtype="mysql"
dbversion="5.1.43-wm3193-log" rev="59858" case="first-letter" rights="Creative
Commons Attribution-Share Alike 3.0 Unported" lang="en"
fallback8bitEncoding="windows-1252" writeapi="" timezone="UTC" timeoffset="0"
articlepath="/wiki/$1" scriptpath="/w" script="/w/index.php"
variantarticlepath="" server="http://en.wikipedia.org"; wikiid="enwiki" />
  </query>
</api>

Under articlepath, it returns "/wiki/$1" when it should return "/wiki/".

This is set by "$data['articlepath'] = $GLOBALS['wgArticlePath'];" in
ApiQuerySiteinfo.php, so this is probably a problem in globals.

-- 
Configure bugmail: https://bugzilla.wikimedia.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

_______________________________________________
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l

Reply via email to