https://bugzilla.wikimedia.org/show_bug.cgi?id=62343

            Bug ID: 62343
           Summary: Gallery image with link=<internal page#section> going
                    to top of <internal page>
           Product: MediaWiki
           Version: 1.21.2
          Hardware: All
                OS: All
            Status: UNCONFIRMED
          Severity: normal
          Priority: Unprioritized
         Component: General/Unknown
          Assignee: wikibugs-l@lists.wikimedia.org
          Reporter: sha...@agent-a.com
       Web browser: ---
   Mobile Platform: ---

Setup:
- have Mediawiki site (Site)
- created a page (Page)
- created section on Page (Section)
- uploaded file to Site (Image.png)

The following does not appear to be working correctly:

<gallery>
File:Image.png|link=Page#Section
</gallery>

Instead of taking me to Page#Section, clicking on this image takes me to the
top of Page.  Oddly, if the Page#Section is part of an external site, it seems
to work (unless a caption is added)

<gallery>
File:Image.png|link=http://www.Site.com/Page#Section
</gallery>

I started a discussion prior to creating this bug report:
http://www.mediawiki.org/wiki/Help_talk:Images#Linked_images_in_gallery

I've also setup a test page on my own wiki site
http://wiki.agent-a.com/Test

-- 
You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
_______________________________________________
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l

Reply via email to