Bug ID: 62888
           Summary: refactor "upload file" step to mediawiki_selenium gem
           Product: Wikimedia
           Version: unspecified
          Hardware: All
                OS: All
            Status: NEW
          Severity: normal
          Priority: Unprioritized
         Component: Quality Assurance
       Web browser: ---
   Mobile Platform: ---

I updated the MobileFrontend repo such that the there is a step "When(/^upload
file (.+)$/) do |file_name|" that exactly matches the same step in the
UploadWizard repo.  The MobileFrontend version was broken in several ways,
notably for Chrome. 

There is also a step in the MobileFrontend repo "When(/^upload bogus file
(.+)$/) do |file_name|" that should also probably move to shared gem. 

Rather than duplicate code, we should put these identical steps in the shared
steps of the mediawiki_selenium gem. 

If we want to do further refactoring, we should do it in the mediawiki_selenium
gem and not in the individual repos.

You are receiving this mail because:
You are the assignee for the bug.
You are on the CC list for the bug.
Wikibugs-l mailing list

Reply via email to