https://bugzilla.wikimedia.org/show_bug.cgi?id=63353

            Bug ID: 63353
           Summary: VisualEditor: Double colons when linking to
                    File/Category
           Product: VisualEditor
           Version: unspecified
          Hardware: All
                OS: All
            Status: NEW
          Severity: normal
          Priority: Unprioritized
         Component: General
          Assignee: jforrester+veteambztick...@wikimedia.org
          Reporter: lokal_pro...@hotmail.com
                CC: jforres...@wikimedia.org, krinklem...@gmail.com,
                    ryasm...@wikimedia.org
       Web browser: Firefox
   Mobile Platform: ---

Intention:
Linking to a file using visual editor

Steps to Reproduce:
1. Edit page on using VE
2. Click add link
3. Enter a filename with File-prefix (e.g. File:Foo.svg)
4. Press enter
5. Press enter again

The same thing happens for categories or if the preceding colon is added
manually.


Actual Results:  
4. Inserted text is changed to :File:Foo.svg
5. Inserted text is changed to ::File:Foo.svg

Expected Results:  
4. As result
5. No change

Reproducible: Sometimes

The same thing happens for categories or if the preceding colon is added
manually. I can get this to happen repeatedly but occasionally VE will
correctly know not to add the second colon (have not identified when though.

-- 
You are receiving this mail because:
You are on the CC list for the bug.
_______________________________________________
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l

Reply via email to