https://bugzilla.wikimedia.org/show_bug.cgi?id=24952

           Summary: Is the seperate Spyc include needed
           Product: MediaWiki extensions
           Version: any
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: minor
          Priority: Normal
         Component: Translate
        AssignedTo: niklas.laxst...@gmail.com
        ReportedBy: s...@reedyboy.net
                CC: s.mazel...@xs4all.nl


The Api had a version of it in ApiFormatYaml_spypc or something. Tim stripped
out a lot of crap from it (security or something).

Noticed you optionally include it

00077     public static function dump( $text ) {
00078         global $wgTranslateYamlLibrary;
00079 
00080         switch ( $wgTranslateYamlLibrary ) {
00081             case 'spyc':
00082                 require_once( dirname( __FILE__ ) . '/../spyc/spyc.php'
);
00083                 return Spyc::YAMLDump( $text );
00084             case 'syck':
00085                 return self::syckDump( $text );
00086             default:
00087                 throw new MWException( "Unknown Yaml library" );
00088         }
00089     }

Do you still need a seperate version?

-- 
Configure bugmail: https://bugzilla.wikimedia.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

_______________________________________________
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l

Reply via email to