https://bugzilla.wikimedia.org/show_bug.cgi?id=25211

           Summary: FCKeditor browser requirement breaks
                    maintenance/update.php
           Product: MediaWiki extensions
           Version: any
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: major
          Priority: Normal
         Component: FCKeditor
        AssignedTo: wikibugs-l@lists.wikimedia.org
        ReportedBy: b...@juliano.info


maintenance/update.php is run from the shell, and many server vars aren't
present for PHP CLI. FCKeditor (in REL1_16_0 at least) tries to access
$_SERVER['HTTP_USER_AGENT'], among others:

.../mediawiki% php maintenance/update.php
PHP Notice:  Undefined index: HTTP_USER_AGENT in
.../mediawiki/extensions/FCKeditor/fckeditor/fckeditor_php5.php on line 37
PHP Stack trace:
PHP   1. {main}() .../mediawiki/maintenance/update.php:0
PHP   2. require_once() .../mediawiki/maintenance/update.php:15
PHP   3. require() .../mediawiki/maintenance/commandLine.inc:45
PHP   4. require_once() .../mediawiki/maintenance/doMaintenance.php:77
PHP   5. include() .../settings/LocalSettings.php:32
PHP   6. require_once() .../settings/GeneralSettings-wiki.php:186
PHP   7. FCKeditor->IsCompatible()
.../mediawiki/extensions/FCKeditor/FCKeditor.php:93
PHP   8. FCKeditor_IsCompatibleBrowser()
.../mediawiki/extensions/FCKeditor/fckeditor/fckeditor_php5.php:208

-- 
Configure bugmail: https://bugzilla.wikimedia.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
You are on the CC list for the bug.

_______________________________________________
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l

Reply via email to