https://bugzilla.wikimedia.org/show_bug.cgi?id=25303

Gurch <matthew.brit...@btinternet.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Summary|Have PARAM_MAX_ENFORCE or   |API: integer parameter
                   |similar                     |validation does not
                   |                            |actually validate, only
                   |                            |warn
           Severity|enhancement                 |normal

--- Comment #2 from Gurch <matthew.brit...@btinternet.com> 2010-10-03 16:58:16 
UTC ---
Changing severity from 'enhancement' to 'normal'. The current behavior, is, if
not actually broken, at least very misleading for extension authors expecting
the API to validate their parameters -- happened once, and will happen again.

The validation should be changed to restrict values to within the min/max range
by default, as well as issuing a warning. Technically this is a BREAKING CHANGE
(omg), but I can't imagine anyone is relying on the existing behavior.

Dying with an error on out of range values is an enhancement that could be
added separately.

Changed summary to better describe the problem.

-- 
Configure bugmail: https://bugzilla.wikimedia.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

_______________________________________________
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l

Reply via email to