https://bugzilla.wikimedia.org/show_bug.cgi?id=22014

--- Comment #4 from Hampton Catlin <hcat...@wikimedia.org> 2010-11-09 12:43:39 
UTC ---
The strangeness with this bug continues. The cache is being cleared. If I
install a fresh copy of mobile, it gets an old version of the page. The data
appears nowhere in the code, at all. 

Using a curl session, I get this: 


About to connect() to th.wikipedia.org port 80 (#0)
*   Trying 91.198.174.232... * Connected to th.wikipedia.org (91.198.174.232)
port 80 (#0)
> GET 
> /wiki/%E0%B8%AA%E0%B8%96%E0%B8%B2%E0%B8%99%E0%B8%B5%E0%B8%A2%E0%B9%88%E0%B8%AD%E0%B8%A2:%E0%B8%AB%E0%B8%99%E0%B9%89%E0%B8%B2%E0%B8%AB%E0%B8%A5%E0%B8%B1%E0%B8%81_%28%E0%B9%82%E0%B8%A1%E0%B8%9A%E0%B8%B2%E0%B8%A2%E0%B8%A5%E0%B9%8C%29
>  HTTP/1.1
Host: th.wikipedia.org
Accept: */*
Accept-Encoding: gzip,deflate
User-Agent: Mozilla/5.0 Wikimedia Mobile
Accept-Charset: utf-8;q=0.7,*;q=0.7

* HTTP 1.0, assume close after body
< HTTP/1.0 200 OK
< Date: Thu, 04 Nov 2010 02:07:34 GMT
< Server: Apache
< Cache-Control: private, s-maxage=0, max-age=0, must-revalidate
< Content-Language: th
< Vary: Accept-Encoding,Cookie
< Last-Modified: Mon, 01 Nov 2010 15:14:05 GMT
< Content-Encoding: gzip
< Content-Length: 10891
< Content-Type: text/html; charset=UTF-8
< X-Cache: HIT from sq60.wikimedia.org
< X-Cache-Lookup: HIT from sq60.wikimedia.org:3128
< Age: 467872
< X-Cache: HIT from amssq34.esams.wikimedia.org
< X-Cache-Lookup: HIT from amssq34.esams.wikimedia.org:3128
< X-Cache: MISS from amssq40.esams.wikimedia.org
< X-Cache-Lookup: MISS from amssq40.esams.wikimedia.org:80
< Connection: close
< 
* Expire cleared
* Closing connection #0

Which, returns HTML that is the exact same as the "old" version. When I view
the same page in my browser, I get a new version.

You can try this yourself if you are on UNIX.

curl -H "Accept: */*" -H "Accept-Encoding: gzip,deflate" -H "Accept-Charset:
utf-8;q=0.7,*;q=0.7" -A "Mozilla/5.0 Wikimedia Mobile"
http://th.wikipedia.org/wiki/%E0%B8%AA%E0%B8%96%E0%B8%B2%E0%B8%99%E0%B8%B5%E0%B8%A2%E0%B9%88%E0%B8%AD%E0%B8%A2:%E0%B8%AB%E0%B8%99%E0%B9%89%E0%B8%B2%E0%B8%AB%E0%B8%A5%E0%B8%B1%E0%B8%81_%28%E0%B9%82%E0%B8%A1%E0%B8%9A%E0%B8%B2%E0%B8%A2%E0%B8%A5%E0%B9%8C%29
-v | gunzip

That causes the problem again. If you want, you can grep the output for words
in either of the pages.

It only occurs when gzip is turned on. If you ask for the non-gzipped page, you
get a fresh copy.

-- 
Configure bugmail: https://bugzilla.wikimedia.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

_______________________________________________
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l

Reply via email to