https://bugzilla.wikimedia.org/show_bug.cgi?id=26685

           Summary: Few help field hint and the related warning messages
                    are ambiguous
           Product: MediaWiki
           Version: 1.18-svn
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: trivial
          Priority: Normal
         Component: Installation
        AssignedTo: wikibugs-l@lists.wikimedia.org
        ReportedBy: nade...@gmail.com
                CC: innocentkil...@gmail.com


Created attachment 7976
  --> https://bugzilla.wikimedia.org/attachment.cgi?id=7976
Database name hyphens

Steps to reproduce:
1. Navigate upto the 'Connect to database' page.
2. Input invalid 'Database name'. (e.g. my_wiki#)
3. Click on the 'Continue' button.
4. Click on the 'help' field hint for the 'Database name'.
5. Compare the warning message and the help field hint.

Note : Same behavior for 'Database table prefix'.  (refer the screenshots)

Actual results:
Warning message - Invalid database name "my_wiki#". Use only ASCII letters
(a-z, A-Z), numbers (0-9), underscores (_) and hyphens (-). 

Help field hint - Choose a name that identifies your wiki. It should not
contain spaces or hyphens. ......

Note : Currently system accepts database names with hyphens.

Expected results:
Either one of the message should be changed.

-- 
Configure bugmail: https://bugzilla.wikimedia.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
You are on the CC list for the bug.

_______________________________________________
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l

Reply via email to