https://bugzilla.wikimedia.org/show_bug.cgi?id=27075

           Summary: Awry behaviour from editor's input validation for
                    <ref> tag.
           Product: MediaWiki
           Version: unspecified
          Platform: All
        OS/Version: All
            Status: NEW
          Keywords: parser
          Severity: normal
          Priority: Normal
         Component: Page editing
        AssignedTo: wikibugs-l@lists.wikimedia.org
        ReportedBy: csiborg.mi...@gmail.com


When the last <ref> tag used is mistakenly left unclosed, an error message
about a missing <references/> tag is issued (localized Romanian text “Eroare la
citare: pagina conţine coduri <ref>, dar lipseşte codul <references/>. ”)
instead of a message indicating the unenclosed tag and none of the folowing
text is rendered in the preview window. The <references> tag was present. 

For me this was a bit confusing at first because coincidentally the faultive
<ref> tag was the last thing in the article. So the only thing not rendered was
the References. :), which, I repeat, was present. 

Here a version made to reproduce the bug :

http://ro.wikipedia.org/w/index.php?title=Montmilch&oldid=5114127

Here the current version

http://ro.wikipedia.org/w/index.php?title=Montmilch&oldid=5114132


Greetings,

csiborg.mirco

-- 
Configure bugmail: https://bugzilla.wikimedia.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.
You are on the CC list for the bug.
_______________________________________________
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l

Reply via email to