Summary: rename curid and wgArticleId to pageid
           Product: MediaWiki
           Version: wikimedia-deployment
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: enhancement
          Priority: Normal
         Component: General/Unknown

curid is an url parameter to index.php. wgArticleId is a JavaScript variable
present in the source code. Both refer to the page_id property of the page in
the database.

They should be renamed to pageid/pageId, for clarity (especially wrt curid) and
consistency (to match page_id in the database and the pageids API parameter).

To complete the set, a magic word would be nice, such as {{PAGEID}}, as simply
a wrapper around wgPageId.

ps - I suppose old names could be kept as aliases for backwards-compatibility.

Configure bugmail:
------- You are receiving this mail because: -------
You are the assignee for the bug.
You are on the CC list for the bug.

Wikibugs-l mailing list

Reply via email to