https://bugzilla.wikimedia.org/show_bug.cgi?id=27549

           Summary: api.php?action=query&list=users&usprop=groups doesn't
                    show implicit groups if a user doesn't have explicit
                    groups
           Product: MediaWiki
           Version: unspecified
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: enhancement
          Priority: Normal
         Component: API
        AssignedTo: roan.katt...@gmail.com
        ReportedBy: liang...@gmail.com
                CC: bryan.tongm...@gmail.com, s...@reedyboy.net,
                    vasi...@gmail.com, soxre...@gmail.com


http://zh.wikipedia.org/w/api.php?format=json&action=query&list=users&usprop=blockinfo|groups|editcount|registration&ususers=Hat600

{"query":{"users":[{"name":"Hat600","editcount":16594,"registration":"2008-09-27T13:27:38Z","groups":["*","user","autoconfirmed","ipblock-exempt","patroller","rollbacker"]}]}}

http://zh.wikipedia.org/w/api.php?format=json&action=query&list=users&usprop=blockinfo|groups|editcount|registration&ususers=GanKeyu

{"query":{"users":[{"name":"GanKeyu","editcount":126,"registration":"2009-01-25T03:15:46Z"}]}}

-- 
Configure bugmail: https://bugzilla.wikimedia.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are on the CC list for the bug.

_______________________________________________
Wikibugs-l mailing list
Wikibugs-l@lists.wikimedia.org
https://lists.wikimedia.org/mailman/listinfo/wikibugs-l

Reply via email to