Lucas_Werkmeister_WMDE created this task.
Lucas_Werkmeister_WMDE added projects: Wikidata, Wikidata-Query-Service.
Restricted Application added a subscriber: Aklapper.

TASK DESCRIPTION
  The RDF value for a Commons Media value is supposed to be an IRI:
  
    SELECT (STR(?image) AS ?str) (ISIRI(?image) AS ?isIri) WHERE {
      wd:Q33231166 wdt:P18 ?image.
    }
  
  | str                                                                         
                                                 | isIri |
  | 
----------------------------------------------------------------------------------------------------------------------------
 | ----- |
  | 
http://commons.wikimedia.org/wiki/Special:FilePath/GuentherZ%202010-02-27%200207%20Wien10%20Scheunenstrasse2%20Bildstock.jpg
 | true  |
  |
  
  However, very occasionally, the query service contains the file name as a 
simple string instead:
  
    SELECT * WHERE {
      ?item wdt:P18 ?image.
      FILTER(DATATYPE(?image) = xsd:string)
    }
    LIMIT 10
  
  
  
  | item | image                                                           |
  | ---- | --------------------------------------------------------------- |
  | wd:Q9151148 | Andrey Ashchev.jpg                                            
  |
  | wd:Q58191231 | 139.Egea (Valle de Lierp) - Iglesia de San Esteban + 
Turbón.jpg |
  | wd:Q58191231 | 141.Egea (Valle de Lierp) - Casa Albañil.jpg                 
   |
  | wd:Q16403761 | Ilmar Mikkor 1960.jpg                                        
   |
  | wd:Q805547 | South end of the isle of Balta - geograph.org.uk - 1357955.jpg 
       |
  | wd:Q21518597 | Hennie at a rugby game.jpg                                   
   |
  | wd:Q78854 | Markus Werba 2009.jpg                                           
|
  | wd:Q16609740 | Museu lousado.JPG                                            
   |
  | wd:Q5390854 | Pueblo de luis.jpg                                            
  |
  | wd:Q5516267 | גד נבון.jpg                                                   
  |
  |
  
  I have no idea why that happens. It could be a bug in the query service, 
mixing up the values somehow (it feels vaguely similar to T255657 
<https://phabricator.wikimedia.org/T255657>); but it could also be a bug in the 
Wikibase RDF export – maybe Wikibase temporarily forgot that P18 
<https://www.wikidata.org/wiki/Property:P18> is a Commons Media property, and 
treated it like a string property instead.

TASK DETAIL
  https://phabricator.wikimedia.org/T258782

EMAIL PREFERENCES
  https://phabricator.wikimedia.org/settings/panel/emailpreferences/

To: Lucas_Werkmeister_WMDE
Cc: Aklapper, Lucas_Werkmeister_WMDE, CBogen, Akuckartz, darthmon_wmde, 
Nandana, Namenlos314, Lahi, Gq86, GoranSMilovanovic, QZanden, EBjune, merbst, 
LawExplorer, _jensen, rosalieper, Scott_WUaS, Jonas, Xmlizer, jkroll, 
Wikidata-bugs, Jdouglas, aude, Tobias1984, Manybubbles, Mbch331
_______________________________________________
Wikidata-bugs mailing list
[email protected]
https://lists.wikimedia.org/mailman/listinfo/wikidata-bugs

Reply via email to