On Tue, Feb 06, 2007 at 07:20:40PM +0100, Felix Nawothnig wrote:
> Marcus Meissner wrote:
> >>>- if(nRelPos>=0) { /* if this or preceding row */
> >>>+ if(nRelPos<=0) { /* if this or preceding row */
> >>> while(nRelPos<=0) {
> >>Shouldn't that become a "do { ... } while()" then?
> >No, since there is a return item; after the while () loop.
>
> I meant replacing just the while(), not the if() while().
>
> It's mostly a matter of style though as gcc most likely will compile it
> to a do {} while() anyway.
I only wanted to do the minimalistic change to avoid
errors creeping in ;)
Ciao, Marcus