https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=13950

            Bug ID: 13950
           Summary: Multiple "Lua: Error during loading" issues reported
                    after install of Win64 version 2.4.0
           Product: Wireshark
           Version: 2.4.0
          Hardware: x86
                OS: Windows 10
            Status: UNCONFIRMED
          Severity: Major
          Priority: Low
         Component: Dissection engine (libwireshark)
          Assignee: bugzilla-ad...@wireshark.org
          Reporter: mba...@activevideo.com
  Target Milestone: ---

Created attachment 15742
  --> https://bugs.wireshark.org/bugzilla/attachment.cgi?id=15742&action=edit
This dissector contains the use of "base.HEX", which the error complains about.
 Is: "base.HEX" somedeprecated

Build Information:
Paste the COMPLETE build information from "Help->About Wireshark", "wireshark
-v", or "tshark -v".
--
Prior to install and launch of Wireshark 2.4.0 for Windows 64, I had none of
the problems described below. However, after the install, I am getting the
following 2 errors reported in a dialog:

Lua: Error during loading: [string "C:\Program
Files\Wireshark\plugins\2.4.0\dsmc..."]:40: bad argument #3 to 'bytes' (Display
must be either base.NONE, base.DOT, base.DASH, base.COLON or base.SPACE) --

Lua: Error during loading: [string "C:\Program
Files\Wireshark\plugins\2.4.0\twcs..."]:426: bad argument #3 to 'new'
(ProtoField_new: Unsupported ProtoField field type) --

The first error
References a dissector named dsmcc_dissector.lua, and line 40 has the following
lua code:
ServerInteractiveSessionRequest.fields.sessionId =
ProtoField.bytes("dsmcc.sessionId", "sessionId", base.HEX, nil, nil)

Referencing the following LUA API link, base.HEX appears to be valid:
https://www.wireshark.org/docs/wsdg_html_chunked/lua_module_Proto.html

2. The second error
References a dissector named twcssp.lua, and line 426 has the following lua
code: local pf_stb_address = ProtoField.new("Unique STB MAC Address",
"dsmcc_ssp.stb_address", ftypes.ETHER)

Referencing the follwing LUA API link, ftypes.ETHER appears also to be valid:
https://wiki.wireshark.org/LuaAPI/Proto#ProtoField

FYI, I just downgraded Win64 wireshark v2.4.0 to Win64 wireshark v2.2.8.
Wireshark now launches, and there are no more "LUA: Error during loading"
messages.

Any help on how to resolve this would be greatly appreciated!

Thanks,

Mike

-- 
You are receiving this mail because:
You are watching all bug changes.
___________________________________________________________________________
Sent via:    Wireshark-bugs mailing list <wireshark-bugs@wireshark.org>
Archives:    https://www.wireshark.org/lists/wireshark-bugs
Unsubscribe: https://www.wireshark.org/mailman/options/wireshark-bugs
             mailto:wireshark-bugs-requ...@wireshark.org?subject=unsubscribe

Reply via email to