--- Comment #8 from Harald Welte <> ---
I've pushed as a possible fix.  It's
fairly trivial, but it feels quite wrong to call a "gsm_a_ccch" dissector with
something that clearly is transportetd over the downlink SACCH and not over the

As dissect_ccch() comments state: "The name CCCH might not be correct!"

So in reality, what dissect_ccch() is, is a RR dissector for the "information
field of LAPDm B4 and Bbis frames".  Maybe it should be renamed? But then, we'd
change the name for register_dissector and would have to rename this in various

You are receiving this mail because:
You are watching all bug changes.
Sent via:    Wireshark-bugs mailing list <>

Reply via email to