Very simple reason for that: We build Wireshark for version Qt 5.3, with VS
2015. Make sure, you are using the same versions of our libraries, if you
are using them in your plugin.

cheers, Roland

On Tue, Apr 10, 2018 at 11:16 PM, Juanjo Martin Carrascosa <jua...@rti.com>
wrote:

> Hi Paul and Pascal,
>
> Interesting theory Paul! I am going to try both and let you know what
> happens.
>
> Regards,
> Juanjo
>
> On Tue, Apr 10, 2018 at 4:48 PM, Paul Offord <paul.off...@advance7.com>
> wrote:
>
>> Hi Juanjo Martin,
>>
>>
>>
>> This feedback might be a bit naïve (particularly as Pascal knows this
>> stuff better than me) but I think it might be down to naming.
>>
>>
>>
>> Assuming:
>>
>>
>>
>>    - Your dissector function is called dissect_shapetype(…)
>>    - Your registration handoff function is called
>>    proto_reg_handoff_shapetype(…)
>>    - Your dissector registration function is called
>>    proto_register_shapetype(…)
>>    - And you register the protocol with an abbreviation shapetype
>>
>>
>>
>> I think you should generate a plugin called shapetype.dll.
>>
>>
>>
>> Best regards…Paul
>>
>>
>>
>> *From:* Wireshark-dev <wireshark-dev-boun...@wireshark.org> *On Behalf
>> Of *Pascal Quantin
>> *Sent:* 10 April 2018 14:58
>> *To:* Developer support list for Wireshark <wireshark-dev@wireshark.org>
>> *Subject:* Re: [Wireshark-dev] Error loading plugin
>>
>>
>>
>> Hi Juanjo,
>>
>>
>>
>> 2018-04-10 14:02 GMT+02:00 Juanjo Martin Carrascosa <jua...@rti.com>:
>>
>> Hi all,
>>
>>
>>
>> I am developing a plugin. It works for me but when I try to give it to
>> other developers, some of them get the following error:
>>
>>
>>
>>
>>
>> I am using VS2012 in Windows 64 bits and I have asked one of the
>> developers to try installing the redistributable for that version and still
>> failing.
>>
>> I have tried searching in the code but I can't find anything that leads
>> me to a solution. Any thoughts?
>>
>>
>>
>> Just some blind guesses based on my past experience:
>>
>> - have you built the plugin against the source code of Wireshark 2.4.X?
>> Wireshark does not ensure (understand systematically breaks in practice)
>> the API between major releases so a plugin built for Wireshark 2.5.1 cannot
>> work with Wireshark 2.4.5
>>
>> - are they running a Wireshark version matching the architecture (x86 vs
>> x64) used to build the plugin (but if I remember correctly the error
>> differs in that case)?
>>
>> - Wireshark 2.4.x official installers use MSVC2015, not 2012. Could you
>> build the plugin using MSVC2015 Community Edition and check whether it
>> works fine?
>>
>> Regards,
>> Pascal.
>>
>> ______________________________________________________________________
>>
>> This message contains confidential information and is intended only for
>> the individual named. If you are not the named addressee you should not
>> disseminate, distribute or copy this e-mail. Please notify the sender
>> immediately by e-mail if you have received this e-mail by mistake and
>> delete this e-mail from your system.
>>
>> Any views or opinions expressed are solely those of the author and do not
>> necessarily represent those of Advance Seven Ltd. E-mail transmission
>> cannot be guaranteed to be secure or error-free as information could be
>> intercepted, corrupted, lost, destroyed, arrive late or incomplete, or
>> contain viruses. The sender therefore does not accept liability for any
>> errors or omissions in the contents of this message, which arise as a
>> result of e-mail transmission.
>>
>> Advance Seven Ltd. Registered in England & Wales numbered 2373877 at
>> Endeavour House, Coopers End Lane, Stansted, Essex CM24 1SJ
>>
>> ______________________________________________________________________
>> This email has been scanned by the Symantec Email Security.cloud service.
>> For more information please visit http://www.symanteccloud.com
>> ______________________________________________________________________
>>
>> ____________________________________________________________
>> _______________
>> Sent via:    Wireshark-dev mailing list <wireshark-dev@wireshark.org>
>> Archives:    https://www.wireshark.org/lists/wireshark-dev
>> Unsubscribe: https://www.wireshark.org/mailman/options/wireshark-dev
>>              mailto:wireshark-dev-requ...@wireshark.org?subject=unsubscr
>> ibe
>>
>
>
>
> --
>
> Juanjo Martin
> Senior Application Engineer
> Professional Services Group
> Office: +34 958 27 88 62
> Mobile: +34 656 30 20 56
> jua...@rti.com
> www.rti.com
>
>
> ____________________________________________________________
> _______________
> Sent via:    Wireshark-dev mailing list <wireshark-dev@wireshark.org>
> Archives:    https://www.wireshark.org/lists/wireshark-dev
> Unsubscribe: https://www.wireshark.org/mailman/options/wireshark-dev
>              mailto:wireshark-dev-requ...@wireshark.org?subject=
> unsubscribe
>
___________________________________________________________________________
Sent via:    Wireshark-dev mailing list <wireshark-dev@wireshark.org>
Archives:    https://www.wireshark.org/lists/wireshark-dev
Unsubscribe: https://www.wireshark.org/mailman/options/wireshark-dev
             mailto:wireshark-dev-requ...@wireshark.org?subject=unsubscribe

Reply via email to