From: "Rodolfo García Peñas (kix)" <[email protected]>

These patches are independent, but all made some code cleanups.

0001-wDockAttachIcon-icon_editing-is-common-in-if-else.patch

This is a simple patch:

if (1) {
 a;
 b;
} else {
 a;
 c;
}

is better as:

a;
if (1)
 b
else
 c

0002-get_default_icon_filename-rewrited.patch

This patch is very interesting. See their description because is too long.
It solves some bugs with icon errors at config file. See your logs now!

This patch also rename the function from get_default_icon_filename() to
get_icon_filename(). Shorter, easiest.

0003-wDefaultGetImage-renamed-to-get_icon_image.patch

To hold the same idea that the before patch, this change the name from
wDefaultGetImage() to get_icon_image().

0004-get_default_image_path-unused-argument.patch

The Screen argument is not used in the function, so can be removed.


-- 
To unsubscribe, send mail to [email protected].

Reply via email to