Dave Tapley wrote:
> Hmm, further to this:
> $ darcs pull
> Pulling from "http://code.haskell.org/wxhaskell";...
> Official wxHaskell darcs repository
> **********************
> No remote changes to pull in!
> $ cd wx
> $ cabal configure
> Resolving dependencies...
> Configuring wx-0.13.1...
> Warning: This package indirectly depends on multiple versions of the same
> package. This is highly likely to cause a compile failure.
> package wxcore-0.13.1 requires containers-
> package wxdirect-0.13.1 requires containers-
> package wxcore-0.13.1 requires parsec-
> package wxdirect-0.13.1 requires parsec-3.1.1

You may need to bump dependency version. Are you using GHC 7.0? The 
easiest way to proceed is probably to copy the version constraints from 
the *latest* packages on hackage:


and then reconfigure, rebuild and reinstall these packages.

Best regards,
Heinrich Apfelmus


Got Input?   Slashdot Needs You.
Take our quick survey online.  Come on, we don't ask for help often.
Plus, you'll get a chance to win $100 to spend on ThinkGeek.
wxhaskell-devel mailing list

Reply via email to