Hi Tom,
Thanks for your reply again. There was a problem with install_name for the Tk 
library. I had to change the Makefile to get the correct install_name to be 
used (this was not in the corresponding 8.5 Makefile, so I suspect that's why 
you didn't see this problem).
However, now I get the same 'couldn't connect' error: as the wish I built 
previously in the unix directory, without frameworks:

bash-3.2$ ./wish8.6-X11 application-specific initialization failed: couldn't 
connect to display 
"/private/tmp/com.apple.launchd.gvNP4b1seM/org.macosforge.xquartz:0"% bash-3.2$ 
otool -L wish8.6-X11 wish8.6-X11:        
/Users/kish/Library/Frameworks/Tk.framework/Versions/8.6-X11/Tk (compatibility 
version 8.6.0, current version 8.6.7)        
/Users/kish/Library/Frameworks/Tcl.framework/Versions/8.6/Tcl (compatibility 
version 8.6.0, current version 8.6.7)        /usr/lib/libSystem.B.dylib 
(compatibility version 1.0.0, current version 1238.50.2)        
/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation 
(compatibility version 150.0.0, current version 1349.64.0)        
/opt/local/lib/libXft.2.dylib (compatibility version 6.0.0, current version 
6.1.0)        /opt/local/lib/libfontconfig.1.dylib (compatibility version 
7.0.0, current version 7.0.0)        /opt/local/lib/libX11.6.dylib 
(compatibility version 10.0.0, current version 10.0.0)        
/opt/X11/lib/libXss.1.dylib (compatibility version 2.0.0, current version 
2.0.0)        /opt/local/lib/libXext.6.dylib (compatibility version 11.0.0, 
current version 11.0.0)        /opt/local/lib/libz.1.dylib (compatibility 
version 1.0.0, current version 1.2.7)        /usr/lib/libgcc_s.1.dylib 
(compatibility version 1.0.0, current version 489.0.0)

This problem seem to be related to building Tk on Sierra. I get the same 
problem building Tk 8.5 and 8.6 in the unix directory, and for 8.6 in the 
macosx directory as above. As the Tk 8.5 wish I built on Mac OS 10.6 from the 
same source runs, I don't think this problem is caused by Tk.Tom, have you 
tried to build your X11 Tk on Sierra and newer? If so, I would like to figure 
out what I am doing differently. Thanks 
Kish Shen
 

    On Thursday, 1 March 2018, 14:56, Tom Lane <t...@sss.pgh.pa.us> wrote:
 

 K Shen <kishs...@yahoo.com> writes:
> Thanks for your reply. I tried to build as you suggested, but was 
> unsuccessful - I can't find wish (or Wish.app directory) in the Tk framework 
> that was created, and I would prefer to build a non-framework version.

The recipe that I showed creates a framework in the directory that you
point to for that, and a fairly normal-looking Tcl/Tk installation in the
PREFIX directory, in particular

$ ls -l tcl8.5/bin
total 72
lrwxr-xr-x  1 tgl  admin      8 Oct 18  2014 tclsh@ -> tclsh8.5
-rwxr-xr-x  1 tgl  admin  12720 Oct 18  2014 tclsh8.5*
lrwxr-xr-x  1 tgl  admin    11 Oct 18  2014 wish-X11@ -> wish8.5-X11
-rwxr-xr-x  1 tgl  admin  17552 Oct 18  2014 wish8.5-X11*

While those executables work fine, you can tell from the file sizes that
something's funny about them, and indeed it turns out that they're mostly
just referencing shared libraries:

$ otool -L tcl8.5/bin/wish8.5-X11 
tcl8.5/bin/wish8.5-X11:
        /Users/tgl/Library/Frameworks/Tk.framework/Versions/8.5-X11/Tk 
(compatibility version 8.5.0, current version 8.5.16)
        /Users/tgl/Library/Frameworks/Tcl.framework/Versions/8.5/Tcl 
(compatibility version 8.5.0, current version 8.5.16)
        /usr/lib/libSystem.B.dylib (compatibility version 1.0.0, current 
version 1197.1.1)
        
/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation 
(compatibility version 150.0.0, current version 855.17.0)
        /opt/X11/lib/libX11.6.dylib (compatibility version 10.0.0, current 
version 10.0.0)
        /opt/X11/lib/libXss.1.dylib (compatibility version 2.0.0, current 
version 2.0.0)
        /opt/X11/lib/libXext.6.dylib (compatibility version 11.0.0, current 
version 11.0.0)

So that's why you can't get rid of the framework part.  But it's not that
big:

$ du -hs /Users/tgl/Library/Frameworks/
8.5M    /Users/tgl/Library/Frameworks/Tcl.framework
7.3M    /Users/tgl/Library/Frameworks/Tk.framework

so personally I see no value in getting rid of it that's worth sweating
over getting the build script to do something it doesn't want to do.

            regards, tom lane

   
 _______________________________________________
Do not post admin requests to the list. They will be ignored.
X11-users mailing list      (X11-users@lists.apple.com)
Help/Unsubscribe/Update your Subscription: 
https://lists.apple.com/mailman/options/x11-users/archive%40mail-archive.com

This email sent to arch...@mail-archive.com

Reply via email to