See 
<http://jenkins.x2go.org:8080/job/python-x2go+nightly+raspbian-jessie/18/display/redirect?page=changes>

Changes:

[mike.gabriel] Makefile.docupload: Add docupdate target. Don't rebuild API doc 
for all

[mike.gabriel] API doc: another white-space cleanup + fixes for all open Sphinx 
Build

[mike.gabriel] docs/Makefile: Use sphinx-build command as found in PATH.

[mike.gabriel] debian/control: Add to Build-Conflicts: python-sphinx. We need 
Python3

[mike.gabriel] python-x2go.spec: Blind shot at attempting API doc build for RPM

------------------------------------------
[...truncated 41.21 KB...]
| Install package build dependencies                                           |
+------------------------------------------------------------------------------+


Setup apt archive
-----------------

Merged Build-Depends: cdbs, debhelper (>= 9~), python (>= 2.6.6-3~), 
python-setuptools, python-gevent, python-paramiko, python-xlib, python3, 
python3-setuptools, python3-gevent, python3-paramiko, python3-xlib, 
python3-sphinx, dh-python, locales
Merged Build-Conflicts: python-sphinx
Filtered Build-Depends: cdbs, debhelper (>= 9~), python (>= 2.6.6-3~), 
python-setuptools, python-gevent, python-paramiko, python-xlib, python3, 
python3-setuptools, python3-gevent, python3-paramiko, python3-xlib, 
python3-sphinx, dh-python, locales
Filtered Build-Conflicts: python-sphinx
dpkg-deb: building package `sbuild-build-depends-python-x2go-dummy' in 
`/<<BUILDDIR>>/resolver-IO7hu8/apt_archive/sbuild-build-depends-python-x2go-dummy.deb'.
dpkg-scanpackages: warning: Packages in archive but missing from override file:
dpkg-scanpackages: warning:   sbuild-build-depends-core-dummy 
sbuild-build-depends-python-x2go-dummy
dpkg-scanpackages: info: Wrote 2 entries to output Packages file.
Ign copy: ./ InRelease
Get:1 copy: ./ Release.gpg [299 B]
Get:2 copy: ./ Release [963 B]
Get:3 copy: ./ Sources [582 B]
Get:4 copy: ./ Packages [659 B]
Fetched 2503 B in 0s (2972 B/s)
Reading package lists...
Hit http://packages.x2go.org jessie InRelease
Hit http://packages.x2go.org jessie/main armhf Packages
Hit http://packages.x2go.org jessie/heuler armhf Packages
Reading package lists...
Reading package lists...

+------------------------------------------------------------------------------+
| Install python-x2go build dependencies (aptitude-based resolver)             |
+------------------------------------------------------------------------------+

Reading package lists...
Building dependency tree...
Reading state information...
aptitude is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
aptitude -y --without-recommends -o Dpkg::Options::=--force-confold -o 
Aptitude::CmdLine::Ignore-Trust-Violations=false -o 
Aptitude::ProblemResolver::StepScore=100 -o 
Aptitude::ProblemResolver::SolutionCost=safety, priority, non-default-versions 
-o Aptitude::ProblemResolver::Hints::KeepDummy=reject 
sbuild-build-depends-python-x2go-dummy :UNINST -o 
Aptitude::ProblemResolver::Keep-All-Level=55000 -o 
Aptitude::ProblemResolver::Remove-Essential-Level=maximum install 
sbuild-build-depends-python-x2go-dummy:armhf
Reading package lists...
Building dependency tree...
Reading state information...
Reading extended state information...
Initializing package states...
Building tag database...
The following NEW packages will be installed:
  bsdmainutils{a} cdbs{a} debhelper{a} dh-python{a} docutils-common{a} 
  file{a} gettext{a} gettext-base{a} groff-base{a} intltool-debian{a} 
  libasprintf0c2{a} libcroco3{a} libexpat1{a} libffi6{a} libglib2.0-0{a} 
  libjs-jquery{a} libjs-sphinxdoc{a} libjs-underscore{a} libmagic1{a} 
  libmpdec2{a} libpipeline1{a} libpython-stdlib{a} libpython2.7-minimal{a} 
  libpython2.7-stdlib{a} libpython3-stdlib{a} libpython3.4-minimal{a} 
  libpython3.4-stdlib{a} libssl1.0.0{a} libunistring0{a} libxml2{a} 
  locales{a} man-db{a} mime-support{a} po-debconf{a} python{a} 
  python-crypto{a} python-ecdsa{a} python-gevent{a} python-greenlet{a} 
  python-minimal{a} python-paramiko{a} python-pkg-resources{a} 
  python-setuptools{a} python-six{a} python-support{a} python-xlib{a} 
  python2.7{a} python2.7-minimal{a} python3{a} python3-crypto{a} 
  python3-docutils{a} python3-ecdsa{a} python3-jinja2{a} 
  python3-markupsafe{a} python3-minimal{a} python3-paramiko{a} 
  python3-pkg-resources{a} python3-pygments{a} python3-roman{a} 
  python3-setuptools{a} python3-six{a} python3-sphinx{a} python3.4{a} 
  python3.4-minimal{a} sbuild-build-depends-python-x2go-dummy{b} 
  sgml-base{a} sphinx-common{a} xml-core{a} 
0 packages upgraded, 68 newly installed, 0 to remove and 0 not upgraded.
Need to get 25.1 MB of archives. After unpacking 93.8 MB will be used.
The following packages have unmet dependencies:
 sbuild-build-depends-python-x2go-dummy : Depends: python3-gevent which is a 
virtual package.
                                          Depends: python3-xlib which is a 
virtual package.
Unable to resolve dependencies!  Giving up...
The following NEW packages will be installed:
  bsdmainutils{a} cdbs{a} debhelper{a} dh-python{a} docutils-common{a} 
  file{a} gettext{a} gettext-base{a} groff-base{a} intltool-debian{a} 
  libasprintf0c2{a} libcroco3{a} libexpat1{a} libffi6{a} libglib2.0-0{a} 
  libjs-jquery{a} libjs-sphinxdoc{a} libjs-underscore{a} libmagic1{a} 
  libmpdec2{a} libpipeline1{a} libpython-stdlib{a} libpython2.7-minimal{a} 
  libpython2.7-stdlib{a} libpython3-stdlib{a} libpython3.4-minimal{a} 
  libpython3.4-stdlib{a} libssl1.0.0{a} libunistring0{a} libxml2{a} 
  locales{a} man-db{a} mime-support{a} po-debconf{a} python{a} 
  python-crypto{a} python-ecdsa{a} python-gevent{a} python-greenlet{a} 
  python-minimal{a} python-paramiko{a} python-pkg-resources{a} 
  python-setuptools{a} python-six{a} python-support{a} python-xlib{a} 
  python2.7{a} python2.7-minimal{a} python3{a} python3-crypto{a} 
  python3-docutils{a} python3-ecdsa{a} python3-jinja2{a} 
  python3-markupsafe{a} python3-minimal{a} python3-paramiko{a} 
  python3-pkg-resources{a} python3-pygments{a} python3-roman{a} 
  python3-setuptools{a} python3-six{a} python3-sphinx{a} python3.4{a} 
  python3.4-minimal{a} sbuild-build-depends-python-x2go-dummy{b} 
  sgml-base{a} sphinx-common{a} xml-core{a} 
0 packages upgraded, 68 newly installed, 0 to remove and 0 not upgraded.
Need to get 25.1 MB of archives. After unpacking 93.8 MB will be used.
Abort.
Not removing installed packages: cloned chroot in use
/usr/bin/du: cannot access '/<<PKGBUILDDIR>>': No such file or directory
E: read_command failed to execute du
E: Cannot determine space needed for /<<PKGBUILDDIR>> (du failed)
Reading package lists...
Building dependency tree...
Reading state information...
  sbuild-build-depends-python-x2go-dummy:armhf Depends on python3-gevent [ 
armhf ] < none > ( none ) can't be satisfied!
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) sbuild-build-depends-python-x2go-dummy [ armhf ] < none -> 
0.invalid.0 > ( unknown )
Broken sbuild-build-depends-python-x2go-dummy:armhf Depends on cdbs [ armhf ] < 
none -> 0.4.130+deb8u1 > ( devel )
  Considering cdbs:armhf 1 as a solution to 
sbuild-build-depends-python-x2go-dummy:armhf 10000
  Re-Instated cdbs:armhf
Broken sbuild-build-depends-python-x2go-dummy:armhf Depends on debhelper [ 
armhf ] < none -> 9.20150101+deb8u2 > ( devel ) (>= 9~)
  Considering debhelper:armhf 0 as a solution to 
sbuild-build-depends-python-x2go-dummy:armhf 10000
  Re-Instated libmagic1:armhf
  Re-Instated file:armhf
  Re-Instated libffi6:armhf
  Re-Instated libglib2.0-0:armhf
  Re-Instated libxml2:armhf
  Re-Instated libcroco3:armhf
  Re-Instated libunistring0:armhf
  Re-Instated libasprintf0c2:armhf
  Re-Instated gettext-base:armhf
  Re-Instated gettext:armhf
  Re-Instated intltool-debian:armhf
  Re-Instated po-debconf:armhf
  Re-Instated groff-base:armhf
  Re-Instated bsdmainutils:armhf
  Re-Instated libpipeline1:armhf
  Re-Instated man-db:armhf
  Re-Instated debhelper:armhf
Broken sbuild-build-depends-python-x2go-dummy:armhf Depends on python [ armhf ] 
< none -> 2.7.9-1 > ( python ) (>= 2.6.6-3~)
  Considering python:armhf 0 as a solution to 
sbuild-build-depends-python-x2go-dummy:armhf 10000
  Re-Instated libpython2.7-minimal:armhf
  Re-Instated python2.7-minimal:armhf
  Re-Instated mime-support:armhf
  Re-Instated libexpat1:armhf
  Re-Instated libssl1.0.0:armhf
  Re-Instated libpython2.7-stdlib:armhf
  Re-Instated python2.7:armhf
  Re-Instated libpython-stdlib:armhf
  Re-Instated python-minimal:armhf
  Re-Instated python:armhf
Broken sbuild-build-depends-python-x2go-dummy:armhf Depends on 
python-setuptools [ armhf ] < none -> 5.5.1-1 > ( python )
  Considering python-setuptools:armhf 1 as a solution to 
sbuild-build-depends-python-x2go-dummy:armhf 10000
  Re-Instated python-pkg-resources:armhf
  Re-Instated python-setuptools:armhf
Broken sbuild-build-depends-python-x2go-dummy:armhf Depends on python-gevent [ 
armhf ] < none -> 1.0.1-2 > ( python )
  Considering python-gevent:armhf 1 as a solution to 
sbuild-build-depends-python-x2go-dummy:armhf 10000
  Re-Instated python-greenlet:armhf
  Re-Instated python-gevent:armhf
Broken sbuild-build-depends-python-x2go-dummy:armhf Depends on python-paramiko 
[ armhf ] < none -> 1.15.1-1 > ( python )
  Considering python-paramiko:armhf 1 as a solution to 
sbuild-build-depends-python-x2go-dummy:armhf 10000
  Re-Instated python-crypto:armhf
  Re-Instated python-six:armhf
  Re-Instated python-ecdsa:armhf
  Re-Instated python-paramiko:armhf
Broken sbuild-build-depends-python-x2go-dummy:armhf Depends on python-xlib [ 
armhf ] < none -> 0.14+20091101-1 > ( python )
  Considering python-xlib:armhf 1 as a solution to 
sbuild-build-depends-python-x2go-dummy:armhf 10000
  Re-Instated python-support:armhf
  Re-Instated python-xlib:armhf
Broken sbuild-build-depends-python-x2go-dummy:armhf Depends on python3 [ armhf 
] < none -> 3.4.2-2 > ( python )
  Considering python3:armhf 1 as a solution to 
sbuild-build-depends-python-x2go-dummy:armhf 10000
  Re-Instated libpython3.4-minimal:armhf
  Re-Instated python3.4-minimal:armhf
  Re-Instated libmpdec2:armhf
  Re-Instated libpython3.4-stdlib:armhf
  Re-Instated python3.4:armhf
  Re-Instated python3-minimal:armhf
  Re-Instated libpython3-stdlib:armhf
  Re-Instated dh-python:armhf
  Re-Instated python3:armhf
Broken sbuild-build-depends-python-x2go-dummy:armhf Depends on 
python3-setuptools [ armhf ] < none -> 5.5.1-1 > ( python )
  Considering python3-setuptools:armhf 1 as a solution to 
sbuild-build-depends-python-x2go-dummy:armhf 10000
  Re-Instated python3-pkg-resources:armhf
  Re-Instated python3-setuptools:armhf
Broken sbuild-build-depends-python-x2go-dummy:armhf Depends on python3-gevent [ 
armhf ] < none > ( none )
Broken sbuild-build-depends-python-x2go-dummy:armhf Depends on python3-paramiko 
[ armhf ] < none -> 1.15.1-1 > ( python )
  Considering python3-paramiko:armhf 1 as a solution to 
sbuild-build-depends-python-x2go-dummy:armhf 10000
  Re-Instated python3-crypto:armhf
  Re-Instated python3-six:armhf
  Re-Instated python3-ecdsa:armhf
  Re-Instated python3-paramiko:armhf
Broken sbuild-build-depends-python-x2go-dummy:armhf Depends on python3-xlib [ 
armhf ] < none > ( none )
Broken sbuild-build-depends-python-x2go-dummy:armhf Depends on python3-sphinx [ 
armhf ] < none -> 1.2.3+dfsg-1 > ( python )
  Considering python3-sphinx:armhf 1 as a solution to 
sbuild-build-depends-python-x2go-dummy:armhf 10000
  Re-Instated python3-roman:armhf
  Re-Instated sgml-base:armhf
  Re-Instated xml-core:armhf
  Re-Instated docutils-common:armhf
  Re-Instated python3-docutils:armhf
  Re-Instated python3-pygments:armhf
  Re-Instated python3-markupsafe:armhf
  Re-Instated python3-jinja2:armhf
  Re-Instated libjs-jquery:armhf
  Re-Instated libjs-underscore:armhf
  Re-Instated libjs-sphinxdoc:armhf
  Re-Instated sphinx-common:armhf
  Re-Instated python3-sphinx:armhf
Broken sbuild-build-depends-python-x2go-dummy:armhf Depends on locales [ armhf 
] < none -> 2.19-18+deb8u10 > ( localization )
  Considering locales:armhf 1 as a solution to 
sbuild-build-depends-python-x2go-dummy:armhf 10000
  Re-Instated locales:armhf
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 sbuild-build-depends-python-x2go-dummy : Depends: python3-gevent but it is not 
installable
                                          Depends: python3-xlib but it is not 
installable
E: Unable to correct problems, you have held broken packages.
apt-get failed.

+------------------------------------------------------------------------------+
| Cleanup                                                                      |
+------------------------------------------------------------------------------+

Purging /<<BUILDDIR>>
Not cleaning session: cloned chroot in use
E: Package build dependencies not satisfied; skipping

+------------------------------------------------------------------------------+
| Summary                                                                      |
+------------------------------------------------------------------------------+

Build Architecture: armhf
Build Type: full
Build-Space: n/a
Build-Time: 0
Distribution: jessie
Fail-Stage: install-deps
Host Architecture: armhf
Install-Time: 0
Job: 
/home/_jenkins_/tmp/tmp.RDWkkV1gxY9h6HD0E8fiwMOb/python-x2go_0.5.99.0-0x2go1~git20180306.1382+8.heuler.1.dsc
Machine Architecture: amd64
Package: python-x2go
Package-Time: 0
Source-Version: 0.5.99.0-0x2go1~git20180306.1382+8.heuler.1
Space: n/a
Status: given-back
Version: 0.5.99.0-0x2go1~git20180306.1382+8.heuler.1
--------------------------------------------------------------------------------
Finished at 2018-03-06T13:25:28Z
Build needed 00:00:00, no disk space
E: Package build dependencies not satisfied; skipping
+ cleanup
+ typeset temp_dir=
+ for temp_dir in "${temp_cleanup[@]}"
+ '[' -n '' ']'
+ for temp_dir in "${temp_cleanup[@]}"
+ '[' -n /var/lib/jenkins/tmp/tmp.RDWkkV1gxY9h6HD0E8fiwMOb ']'
+ '[' -d /var/lib/jenkins/tmp/tmp.RDWkkV1gxY9h6HD0E8fiwMOb ']'
+ rm -Rf -- /var/lib/jenkins/tmp/tmp.RDWkkV1gxY9h6HD0E8fiwMOb
Build step 'Execute shell' marked build as failure
_______________________________________________
x2go-commits mailing list
x2go-commits@lists.x2go.org
https://lists.x2go.org/listinfo/x2go-commits

Reply via email to