See 
<http://jenkins.x2go.org:8080/job/python-x2go+nightly+debian-jessie/129/display/redirect?page=changes>

Changes:

[mike.gabriel] API documentation: Convert class name only links to reST links.

[mike.gabriel] API documentation: Convert full class name path links to reST 
links.

[mike.gabriel] API doc: Switch to 'classic' theme.

[mike.gabriel] x2go/client.py: Fix a __doc__ string head line.

[mike.gabriel] Makefile.docupload: Add clean target.

[mike.gabriel] Makefile.docupload: whitespace fix.

[mike.gabriel] Drop unit test framework. Never really used (though we should 
have).

------------------------------------------
[...truncated 37.21 KB...]
| Install package build dependencies                                           |
+------------------------------------------------------------------------------+


Setup apt archive
-----------------

Merged Build-Depends: cdbs, debhelper (>= 9~), python (>= 2.6.6-3~), 
python-setuptools, python-gevent, python-paramiko, python-xlib, python3, 
python3-setuptools, python3-gevent, python3-paramiko, python3-xlib, 
python3-sphinx, dh-python, locales
Merged Build-Conflicts: python-sphinx
Filtered Build-Depends: cdbs, debhelper (>= 9~), python (>= 2.6.6-3~), 
python-setuptools, python-gevent, python-paramiko, python-xlib, python3, 
python3-setuptools, python3-gevent, python3-paramiko, python3-xlib, 
python3-sphinx, dh-python, locales
Filtered Build-Conflicts: python-sphinx
dpkg-deb: building package `sbuild-build-depends-python-x2go-dummy' in 
`/<<BUILDDIR>>/resolver-navNTy/apt_archive/sbuild-build-depends-python-x2go-dummy.deb'.
dpkg-scanpackages: warning: Packages in archive but missing from override file:
dpkg-scanpackages: warning:   sbuild-build-depends-core-dummy 
sbuild-build-depends-python-x2go-dummy
dpkg-scanpackages: info: Wrote 2 entries to output Packages file.
Ign copy: ./ InRelease
Get:1 copy: ./ Release.gpg [299 B]
Get:2 copy: ./ Release [963 B]
Get:3 copy: ./ Sources [582 B]
Get:4 copy: ./ Packages [660 B]
Fetched 2504 B in 0s (2694 B/s)
Reading package lists...
Hit http://packages.x2go.org jessie InRelease
Hit http://packages.x2go.org jessie/main amd64 Packages
Hit http://packages.x2go.org jessie/heuler amd64 Packages
Reading package lists...
Reading package lists...

+------------------------------------------------------------------------------+
| Install python-x2go build dependencies (aptitude-based resolver)             |
+------------------------------------------------------------------------------+

Reading package lists...
Building dependency tree...
Reading state information...
aptitude is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
aptitude -y --without-recommends -o Dpkg::Options::=--force-confold -o 
Aptitude::CmdLine::Ignore-Trust-Violations=false -o 
Aptitude::ProblemResolver::StepScore=100 -o 
Aptitude::ProblemResolver::SolutionCost=safety, priority, non-default-versions 
-o Aptitude::ProblemResolver::Hints::KeepDummy=reject 
sbuild-build-depends-python-x2go-dummy :UNINST -o 
Aptitude::ProblemResolver::Keep-All-Level=55000 -o 
Aptitude::ProblemResolver::Remove-Essential-Level=maximum install 
sbuild-build-depends-python-x2go-dummy:amd64
Reading package lists...
Building dependency tree...
Reading state information...
Reading extended state information...
Initializing package states...
Building tag database...
The following NEW packages will be installed:
  bsdmainutils{a} cdbs{a} debhelper{a} dh-python{a} docutils-common{a} 
  file{a} gettext{a} gettext-base{a} groff-base{a} intltool-debian{a} 
  libasprintf0c2{a} libcroco3{a} libexpat1{a} libffi6{a} libglib2.0-0{a} 
  libjs-jquery{a} libjs-sphinxdoc{a} libjs-underscore{a} libmagic1{a} 
  libmpdec2{a} libpipeline1{a} libpython-stdlib{a} libpython2.7-minimal{a} 
  libpython2.7-stdlib{a} libpython3-stdlib{a} libpython3.4-minimal{a} 
  libpython3.4-stdlib{a} libssl1.0.0{a} libunistring0{a} libxml2{a} 
  locales{a} man-db{a} mime-support{a} po-debconf{a} python{a} 
  python-crypto{a} python-ecdsa{a} python-gevent{a} python-greenlet{a} 
  python-minimal{a} python-paramiko{a} python-pkg-resources{a} 
  python-setuptools{a} python-six{a} python-support{a} python-xlib{a} 
  python2.7{a} python2.7-minimal{a} python3{a} python3-crypto{a} 
  python3-docutils{a} python3-ecdsa{a} python3-jinja2{a} 
  python3-markupsafe{a} python3-minimal{a} python3-paramiko{a} 
  python3-pkg-resources{a} python3-pygments{a} python3-roman{a} 
  python3-setuptools{a} python3-six{a} python3-sphinx{a} python3.4{a} 
  python3.4-minimal{a} sbuild-build-depends-python-x2go-dummy{b} 
  sgml-base{a} sphinx-common{a} xml-core{a} 
0 packages upgraded, 68 newly installed, 0 to remove and 0 not upgraded.
Need to get 26.6 MB of archives. After unpacking 101 MB will be used.
The following packages have unmet dependencies:
 sbuild-build-depends-python-x2go-dummy : Depends: python3-gevent which is a 
virtual package.
                                          Depends: python3-xlib which is a 
virtual package.
Unable to resolve dependencies!  Giving up...
The following NEW packages will be installed:
  bsdmainutils{a} cdbs{a} debhelper{a} dh-python{a} docutils-common{a} 
  file{a} gettext{a} gettext-base{a} groff-base{a} intltool-debian{a} 
  libasprintf0c2{a} libcroco3{a} libexpat1{a} libffi6{a} libglib2.0-0{a} 
  libjs-jquery{a} libjs-sphinxdoc{a} libjs-underscore{a} libmagic1{a} 
  libmpdec2{a} libpipeline1{a} libpython-stdlib{a} libpython2.7-minimal{a} 
  libpython2.7-stdlib{a} libpython3-stdlib{a} libpython3.4-minimal{a} 
  libpython3.4-stdlib{a} libssl1.0.0{a} libunistring0{a} libxml2{a} 
  locales{a} man-db{a} mime-support{a} po-debconf{a} python{a} 
  python-crypto{a} python-ecdsa{a} python-gevent{a} python-greenlet{a} 
  python-minimal{a} python-paramiko{a} python-pkg-resources{a} 
  python-setuptools{a} python-six{a} python-support{a} python-xlib{a} 
  python2.7{a} python2.7-minimal{a} python3{a} python3-crypto{a} 
  python3-docutils{a} python3-ecdsa{a} python3-jinja2{a} 
  python3-markupsafe{a} python3-minimal{a} python3-paramiko{a} 
  python3-pkg-resources{a} python3-pygments{a} python3-roman{a} 
  python3-setuptools{a} python3-six{a} python3-sphinx{a} python3.4{a} 
  python3.4-minimal{a} sbuild-build-depends-python-x2go-dummy{b} 
  sgml-base{a} sphinx-common{a} xml-core{a} 
0 packages upgraded, 68 newly installed, 0 to remove and 0 not upgraded.
Need to get 26.6 MB of archives. After unpacking 101 MB will be used.
Abort.
Not removing installed packages: cloned chroot in use
du: cannot access '/<<PKGBUILDDIR>>': No such file or directory
E: read_command failed to execute du
E: Cannot determine space needed for /<<PKGBUILDDIR>> (du failed)
Reading package lists...
Building dependency tree...
Reading state information...
  sbuild-build-depends-python-x2go-dummy:amd64 Depends on python3-gevent [ 
amd64 ] < none > ( none ) can't be satisfied!
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) sbuild-build-depends-python-x2go-dummy [ amd64 ] < none -> 
0.invalid.0 > ( unknown )
Broken sbuild-build-depends-python-x2go-dummy:amd64 Depends on cdbs [ amd64 ] < 
none -> 0.4.130+deb8u1 > ( devel )
  Considering cdbs:amd64 1 as a solution to 
sbuild-build-depends-python-x2go-dummy:amd64 10000
  Re-Instated cdbs:amd64
Broken sbuild-build-depends-python-x2go-dummy:amd64 Depends on debhelper [ 
amd64 ] < none -> 9.20150101+deb8u2 > ( devel ) (>= 9~)
  Considering debhelper:amd64 0 as a solution to 
sbuild-build-depends-python-x2go-dummy:amd64 10000
  Re-Instated libmagic1:amd64
  Re-Instated file:amd64
  Re-Instated libffi6:amd64
  Re-Instated libglib2.0-0:amd64
  Re-Instated libxml2:amd64
  Re-Instated libcroco3:amd64
  Re-Instated libunistring0:amd64
  Re-Instated libasprintf0c2:amd64
  Re-Instated gettext-base:amd64
  Re-Instated gettext:amd64
  Re-Instated intltool-debian:amd64
  Re-Instated po-debconf:amd64
  Re-Instated groff-base:amd64
  Re-Instated bsdmainutils:amd64
  Re-Instated libpipeline1:amd64
  Re-Instated man-db:amd64
  Re-Instated debhelper:amd64
Broken sbuild-build-depends-python-x2go-dummy:amd64 Depends on python [ amd64 ] 
< none -> 2.7.9-1 > ( python ) (>= 2.6.6-3~)
  Considering python:amd64 0 as a solution to 
sbuild-build-depends-python-x2go-dummy:amd64 10000
  Re-Instated libpython2.7-minimal:amd64
  Re-Instated python2.7-minimal:amd64
  Re-Instated mime-support:amd64
  Re-Instated libexpat1:amd64
  Re-Instated libssl1.0.0:amd64
  Re-Instated libpython2.7-stdlib:amd64
  Re-Instated python2.7:amd64
  Re-Instated libpython-stdlib:amd64
  Re-Instated python-minimal:amd64
  Re-Instated python:amd64
Broken sbuild-build-depends-python-x2go-dummy:amd64 Depends on 
python-setuptools [ amd64 ] < none -> 5.5.1-1 > ( python )
  Considering python-setuptools:amd64 1 as a solution to 
sbuild-build-depends-python-x2go-dummy:amd64 10000
  Re-Instated python-pkg-resources:amd64
  Re-Instated python-setuptools:amd64
Broken sbuild-build-depends-python-x2go-dummy:amd64 Depends on python-gevent [ 
amd64 ] < none -> 1.0.1-2 > ( python )
  Considering python-gevent:amd64 1 as a solution to 
sbuild-build-depends-python-x2go-dummy:amd64 10000
  Re-Instated python-greenlet:amd64
  Re-Instated python-gevent:amd64
Broken sbuild-build-depends-python-x2go-dummy:amd64 Depends on python-paramiko 
[ amd64 ] < none -> 1.15.1-1 > ( python )
  Considering python-paramiko:amd64 1 as a solution to 
sbuild-build-depends-python-x2go-dummy:amd64 10000
  Re-Instated python-crypto:amd64
  Re-Instated python-six:amd64
  Re-Instated python-ecdsa:amd64
  Re-Instated python-paramiko:amd64
Broken sbuild-build-depends-python-x2go-dummy:amd64 Depends on python-xlib [ 
amd64 ] < none -> 0.14+20091101-1 > ( python )
  Considering python-xlib:amd64 1 as a solution to 
sbuild-build-depends-python-x2go-dummy:amd64 10000
  Re-Instated python-support:amd64
  Re-Instated python-xlib:amd64
Broken sbuild-build-depends-python-x2go-dummy:amd64 Depends on python3 [ amd64 
] < none -> 3.4.2-2 > ( python )
  Considering python3:amd64 1 as a solution to 
sbuild-build-depends-python-x2go-dummy:amd64 10000
  Re-Instated libpython3.4-minimal:amd64
  Re-Instated python3.4-minimal:amd64
  Re-Instated libmpdec2:amd64
  Re-Instated libpython3.4-stdlib:amd64
  Re-Instated python3.4:amd64
  Re-Instated python3-minimal:amd64
  Re-Instated libpython3-stdlib:amd64
  Re-Instated dh-python:amd64
  Re-Instated python3:amd64
Broken sbuild-build-depends-python-x2go-dummy:amd64 Depends on 
python3-setuptools [ amd64 ] < none -> 5.5.1-1 > ( python )
  Considering python3-setuptools:amd64 1 as a solution to 
sbuild-build-depends-python-x2go-dummy:amd64 10000
  Re-Instated python3-pkg-resources:amd64
  Re-Instated python3-setuptools:amd64
Broken sbuild-build-depends-python-x2go-dummy:amd64 Depends on python3-gevent [ 
amd64 ] < none > ( none )
Broken sbuild-build-depends-python-x2go-dummy:amd64 Depends on python3-paramiko 
[ amd64 ] < none -> 1.15.1-1 > ( python )
  Considering python3-paramiko:amd64 1 as a solution to 
sbuild-build-depends-python-x2go-dummy:amd64 10000
  Re-Instated python3-crypto:amd64
  Re-Instated python3-six:amd64
  Re-Instated python3-ecdsa:amd64
  Re-Instated python3-paramiko:amd64
Broken sbuild-build-depends-python-x2go-dummy:amd64 Depends on python3-xlib [ 
amd64 ] < none > ( none )
Broken sbuild-build-depends-python-x2go-dummy:amd64 Depends on python3-sphinx [ 
amd64 ] < none -> 1.2.3+dfsg-1 > ( python )
  Considering python3-sphinx:amd64 1 as a solution to 
sbuild-build-depends-python-x2go-dummy:amd64 10000
  Re-Instated python3-roman:amd64
  Re-Instated sgml-base:amd64
  Re-Instated xml-core:amd64
  Re-Instated docutils-common:amd64
  Re-Instated python3-docutils:amd64
  Re-Instated python3-pygments:amd64
  Re-Instated python3-markupsafe:amd64
  Re-Instated python3-jinja2:amd64
  Re-Instated libjs-jquery:amd64
  Re-Instated libjs-underscore:amd64
  Re-Instated libjs-sphinxdoc:amd64
  Re-Instated sphinx-common:amd64
  Re-Instated python3-sphinx:amd64
Broken sbuild-build-depends-python-x2go-dummy:amd64 Depends on locales [ amd64 
] < none -> 2.19-18+deb8u10 > ( localization )
  Considering locales:amd64 1 as a solution to 
sbuild-build-depends-python-x2go-dummy:amd64 10000
  Re-Instated locales:amd64
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 sbuild-build-depends-python-x2go-dummy : Depends: python3-gevent but it is not 
installable
                                          Depends: python3-xlib but it is not 
installable
E: Unable to correct problems, you have held broken packages.
apt-get failed.

+------------------------------------------------------------------------------+
| Cleanup                                                                      |
+------------------------------------------------------------------------------+

Purging /<<BUILDDIR>>
Not cleaning session: cloned chroot in use
E: Package build dependencies not satisfied; skipping

+------------------------------------------------------------------------------+
| Summary                                                                      |
+------------------------------------------------------------------------------+

Build Architecture: amd64
Build Type: full
Build-Space: n/a
Build-Time: 0
Distribution: jessie
Fail-Stage: install-deps
Host Architecture: amd64
Install-Time: 0
Job: 
/home/_jenkins_/tmp/tmp.7ONeOn3OOJb9bEtfRfRrMwMn/python-x2go_0.5.99.0-0x2go1~git20180306.1389+8.heuler.1.dsc
Machine Architecture: amd64
Package: python-x2go
Package-Time: 0
Source-Version: 0.5.99.0-0x2go1~git20180306.1389+8.heuler.1
Space: n/a
Status: given-back
Version: 0.5.99.0-0x2go1~git20180306.1389+8.heuler.1
--------------------------------------------------------------------------------
Finished at 2018-03-06T19:35:45Z
Build needed 00:00:00, no disk space
E: Package build dependencies not satisfied; skipping
+ cleanup
+ typeset temp_dir=
+ for temp_dir in "${temp_cleanup[@]}"
+ '[' -n '' ']'
+ for temp_dir in "${temp_cleanup[@]}"
+ '[' -n /var/lib/jenkins/tmp/tmp.7ONeOn3OOJb9bEtfRfRrMwMn ']'
+ '[' -d /var/lib/jenkins/tmp/tmp.7ONeOn3OOJb9bEtfRfRrMwMn ']'
+ rm -Rf -- /var/lib/jenkins/tmp/tmp.7ONeOn3OOJb9bEtfRfRrMwMn
Build step 'Execute shell' marked build as failure
_______________________________________________
x2go-commits mailing list
x2go-commits@lists.x2go.org
https://lists.x2go.org/listinfo/x2go-commits

Reply via email to