On 08/21/2016 02:34 AM, Mihai Moldovan wrote:
> On 19.08.2016 07:49 PM, Orion Poplawski wrote:
>> What's the purpose behind the x2goagent-virtual provides?  Are there going to
>> be multiple implementations of the x2goagent that provide it?
>> Also, all Obsoletes should specify a version so that the name can be
>> re-introduced in the future.
> x2goserver-x2goagent provides the x2goagent functionality for nx-libs 3.5.99 
> and
> higher, while nx-libs < 3.5.99 ships the x2goagent package. Both are supposed 
> to
> satisfy x2goagent-virtual (i.e., we want one of them, but don't care about 
> what
> package is installed as such. x2goserver-x2goagent will conflict with nx-libs 
> <
> 3.5.99, though.)

So you can use x2goserver 4.1 with nx-libs < 3.5.99?

I don't see why you don't just do in x2goserver:

Requires: x2gogent >= 4.1

%package -n x2goagent

and then you don't need the following, but otherwise:

> Regarding the second point... would "Obsoletes: x2goagent < 3.5.99" be better?

The version should be higher than the last one from nx-libs.  Not sure exactly
what that is, perhaps "3.6.0-1".  But yes, you need a version.

Orion Poplawski
Technical Manager                     303-415-9701 x222
NWRA, Boulder/CoRA Office             FAX: 303-415-9702
3380 Mitchell Lane                       or...@nwra.com
Boulder, CO 80301                   http://www.nwra.com
x2go-dev mailing list

Reply via email to