What happens if you try to upgrade nxagent?
sudo apt-get install nxagent x2goagent x2goserver

Sent from my Android smartphone

On Sep 20, 2016 1:49 PM, "Robert Dinse" <nan...@eskimo.com> wrote:

>
>      Still can't install x2goserver, needs x2goagent, x2goagent needs
> nxagent:
>
> apt-get purge libnx-x11
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Package 'libnx-x11' is not installed, so not removed
> 0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.
> root@ftp:~# apt-get install libnx-x11-6
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> The following additional packages will be installed:
>   libxcomp3 nx-x11-common
> The following NEW packages will be installed:
>   libnx-x11-6 libxcomp3 nx-x11-common
> 0 upgraded, 3 newly installed, 0 to remove and 5 not upgraded.
> Need to get 910 kB of archives.
> After this operation, 2,288 kB of additional disk space will be used.
> Do you want to continue? [Y/n] y
> Get:1 http://packages.arctica-project.org/ubuntu xenial/main amd64
> libxcomp3 amd64 2:3.5.99.1-0.1+git20160913.1427+16.04.release.1 [373 kB]
> Get:2 http://packages.arctica-project.org/ubuntu xenial/main amd64
> nx-x11-common all 2:3.5.99.1-0.1+git20160913.1427+16.04.release.1 [33.5
> kB]
> Get:3 http://packages.arctica-project.org/ubuntu xenial/main amd64
> libnx-x11-6 amd64 2:3.5.99.1-0.1+git20160913.1427+16.04.release.1 [503 kB]
> Fetched 910 kB in 4s (210 kB/s)
> Selecting previously unselected package libxcomp3:amd64.
> (Reading database ... 383299 files and directories currently installed.)
> Preparing to unpack .../libxcomp3_2%3a3.5.99.1-0.1
> +git20160913.1427+16.04.release.1_amd64.deb ...
> Unpacking libxcomp3:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1)
> ...
> Selecting previously unselected package nx-x11-common.
> Preparing to unpack .../nx-x11-common_2%3a3.5.99.1-0.1+git20160913.1427+
> 16.04.release.1_all.deb ...
> Unpacking nx-x11-common (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1)
> ...
> Selecting previously unselected package libnx-x11-6:amd64.
> Preparing to unpack .../libnx-x11-6_2%3a3.5.99.1-0
> .1+git20160913.1427+16.04.release.1_amd64.deb ...
> Unpacking libnx-x11-6:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1)
> ...
> Processing triggers for libc-bin (2.23-0ubuntu3) ...
> Processing triggers for doc-base (0.10.7) ...
> Processing 1 added doc-base file...
> Registering documents with scrollkeeper...
> Setting up libxcomp3:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1)
> ...
> Setting up nx-x11-common (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1)
> ...
> Setting up libnx-x11-6:amd64 (2:3.5.99.1-0.1+git20160913.1427+16.04.release.1)
> ...
> Processing triggers for libc-bin (2.23-0ubuntu3) ...
> root@ftp:~# apt-get install x2goserver
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
>  x2goserver : Depends: x2goagent (>= 2:3.5.0.25-0~) but it is not going to
> be installed
> E: Unable to correct problems, you have held broken packages.
> root@ftp:~# apt-get install x2goagent
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
>  x2goagent : Depends: nxagent (< 2:3.5.0.32-0~668~ubuntu16.04.1.1)
> E: Unable to correct problems, you have held broken packages.
>
>
> -_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_-_
> -_-_-_-_-_-_-_-_-_-
>  Eskimo North Linux Friendly Internet Access, Shell Accounts, and Hosting.
>    Knowledgeable human assistance, not telephone trees or script readers.
>  See our web site: http://www.eskimo.com/ (206) 812-0051 or (800) 246-6874
> .
>
> On Tue, 20 Sep 2016, Mike DePaulo wrote:
>
> Date: Tue, 20 Sep 2016 09:48:29 -0400
>> From: Mike DePaulo <mikedep...@gmail.com>
>> To: Robert Dinse <nan...@eskimo.com>
>> Cc: "x2go-user@lists.x2go.org" <x2go-user@lists.x2go.org>
>> Subject: Re: Upgrading to nx-libs 3.5.99.1
>>
>> As of nx-libs 3.5.0, libnx-x11 is a transitional dummy package and can
>> be safely removed.
>>
>> As of nx-libs 3.6 beta, libnx-x11 no longer exists.
>>
>> So run:
>>
>> sudo apt-get purge libnx-x11
>> sudo apt-get install libnx-x11-6
>>
>> -Mike
>>
>> On Tue, Sep 20, 2016 at 12:12 AM, Robert Dinse <nan...@eskimo.com> wrote:
>>
>>>
>>>      I am trying to upgrade another Ubuntu server after having done so
>>> successfully on one but I am getting stuck at:
>>>
>>> apt-get install libnx-x11
>>> Reading package lists... Done
>>> Building dependency tree
>>> Reading state information... Done
>>> Some packages could not be installed. This may mean that you have
>>> requested an impossible situation or if you are using the unstable
>>> distribution that some required packages have not yet been created
>>> or been moved out of Incoming.
>>> The following information may help to resolve the situation:
>>>
>>> The following packages have unmet dependencies:
>>>  libnx-x11 : Depends: libnx-x11-6 (< 2:3.5.0.32-0~668~ubuntu16.04.1.1)
>>> but
>>> 2:3.5.99.1-0.1+git20160913.1427+16.04.release.1 is to be installed
>>> E: Unable to correct problems, you have held broken packages.
>>> [...]
>>>
>>
>>
_______________________________________________
x2go-user mailing list
x2go-user@lists.x2go.org
http://lists.x2go.org/listinfo/x2go-user

Reply via email to