Hi,

I'm running X2Go Client 4.1.0.0 on Windows Server 2012 R2 for connecting to 
X2Go Server 4.0.1.22 on Ubuntu 14.04. This usually works flawlessly. Since 
about 4 months ago, however, X2Go Client *sometimes* fails to fully establish 
the session. (Sometimes means that it happens quite unregularly; which makes it 
hard to reproduce. But when it happens, it can last from 5 minutes up to around 
30 minutes until connections are successful again.) In these cases X2Go Client 
actually connects to the server, but the startup of VcXsrv fails, so X2Go 
Client subsequently terminates the connection. I attached the log output of 
VcXsrv below.
I suspect that in the cases when the connection fails to fully establish, 
VcXsrv for some reason doesn't manage to find a free display number.
Maybe this is due to the fact that on the Windows server several users are 
logged in simultaneously and use X2Go Client. Another guess is that VcXsrv 
might not like the fact that the Windows server has two IPv4 addresses.
Does anyone have a clue what could be the reason for it? Or where I could find 
further information on these error messages? Thank you for any hint.


On the client side, the following is logged in 
C:\Users\<username>\AppData\Local\Temp\VCXSrv.0.log when the connection fails:

--
Welcome to the VcXsrv X Server
Vendor: The X2Go and Arctica Projects
Release: 1.17.0.0

OS: Windows NT 6.2 build 9200 (WoW64)
Contact: https://github.com/ArcticaProject/vcxsrv

_XSERVTransSocketCreateListener: failed to bind listener
_XSERVTransSocketINETCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: failed to create listener for inet
DefineSelf - d16s003 has IPv6 addresses...
 ::1
LoadPreferences: C:\Users\<username>\AppData\Roaming/.XWinrc not found
LoadPreferences: Loading P:\X2Go\V4_1_0_0\x2goclient\vcxsrv\system.XWinrc
Warning: Locale not supported by X, falling back to 'C' locale.
wglwrap: Can't resolve "wglGetExtensionsStringARB"
(EE) AIGLX: Won't use generic native renderer as it is not accelerated
(II) AIGLX: Loaded and initialized swrast
(II) GLX: Initialized DRISWRAST GL provider for screen 0
winBlockHandler - pthread_mutex_unlock()
winInitMultiWindowWM - Could not open display, try: 1, sleeping: 5
winInitMultiWindowWM - Could not open display, try: 2, sleeping: 5
winInitMultiWindowWM - Could not open display, try: 3, sleeping: 5
winInitMultiWindowWM - Could not open display, try: 4, sleeping: 5
winInitMultiWindowWM - Could not open display, try: 5, sleeping: 5
winInitMultiWindowWM - Failed opening the display.  Exiting.
(EE) Server terminated with error (1). Closing log file.
--


In the case of successful connection, the log output looks like:

--
Welcome to the VcXsrv X Server
Vendor: The X2Go and Arctica Projects
Release: 1.17.0.0

OS: Windows NT 6.2 build 9200 (WoW64)
Contact: https://github.com/ArcticaProject/vcxsrv

DefineSelf - d16s003 has 2 usable IPv4 interfaces...
 addresses 10.36.2.103 10.36.18.106
DefineSelf - d16s003 has IPv6 addresses...
 ::1
LoadPreferences: C:\Users\<uername>\AppData\Roaming/.XWinrc not found
LoadPreferences: Loading P:\X2Go\V4_1_0_0\x2goclient\vcxsrv\system.XWinrc
Warning: Locale not supported by X, falling back to 'C' locale.
wglwrap: Can't resolve "wglGetExtensionsStringARB"
(EE) AIGLX: Won't use generic native renderer as it is not accelerated
(II) AIGLX: Loaded and initialized swrast
(II) GLX: Initialized DRISWRAST GL provider for screen 0
winBlockHandler - pthread_mutex_unlock()
winClipboardThreadProc - DISPLAY=127.0.0.1:0.0
--


When I just start vcxsrv.exe, I'm getting the same messages. At times when 
connections fail:

--
Welcome to the VcXsrv X Server
Vendor: The X2Go and Arctica Projects
Release: 1.17.0.0

OS: Windows NT 6.2 build 9200 (WoW64)
Contact: https://github.com/ArcticaProject/vcxsrv

_XSERVTransSocketCreateListener: failed to bind listener
_XSERVTransSocketINETCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: failed to create listener for inet
DefineSelf - d16s003 has IPv6 addresses...
 ::1
LoadPreferences: C:\Users\<username>\AppData\Roaming/.XWinrc not found
LoadPreferences: Loading P:\X2Go\V4_1_0_0\x2goclient\VcXsrv\system.XWinrc
Warning: Locale not supported by X, falling back to 'C' locale.
(EE) AIGLX: No native OpenGL in modes with a root window
(II) AIGLX: Loaded and initialized swrast
(II) GLX: Initialized DRISWRAST GL provider for screen 0
winBlockHandler - pthread_mutex_unlock()
--


At times when connections work:

--
Welcome to the VcXsrv X Server
Vendor: The X2Go and Arctica Projects
Release: 1.17.0.0

OS: Windows NT 6.2 build 9200 (WoW64)
Contact: https://github.com/ArcticaProject/vcxsrv

DefineSelf - d16s003 has 2 usable IPv4 interfaces...
 addresses 10.36.2.103 10.36.18.106
DefineSelf - d16s003 has IPv6 addresses...
 ::1
LoadPreferences: C:\Users\<username>\AppData\Roaming/.XWinrc not found
LoadPreferences: Loading P:\X2Go\V4_1_0_0\x2goclient\VcXsrv\system.XWinrc
Warning: Locale not supported by X, falling back to 'C' locale.
(EE) AIGLX: No native OpenGL in modes with a root window
(II) AIGLX: Loaded and initialized swrast
(II) GLX: Initialized DRISWRAST GL provider for screen 0
winBlockHandler - pthread_mutex_unlock()
--


Best,
Andy
_______________________________________________
x2go-user mailing list
x2go-user@lists.x2go.org
https://lists.x2go.org/listinfo/x2go-user

Reply via email to