No it only works on the console (through spice/vnc in this case, but display is :0 )

and I need to do a 'xhost +' first (not needed on my laptop strangely)

With the x2go remote display it simply don't work (not via unix socket, or tcp or hard coded $DISPLAY with the IP of the docker host)



On 16-04-18 16:05, Ulrich Sibiller wrote:
Hmm, if it works with xhost+ this looks like a cookie issue. Do you
have the matching cookie in your docker session (xauth list)?

Uli

On Mon, Apr 16, 2018 at 3:28 PM, Bas van den Heuvel
<b...@better-it-solutions.nl> wrote:
I've tried all variations of $DISPLAY.

Also tried to use xhost+ etc. etc.

and my firefox docker contains the X unix socket.

It works on my laptop without additional work (same docker version)

It works on the x2go machine (connected through VNC/Spice) when I issue
xhost + first

It simply doesn't work when I use the x2go display

Any ideas ?

It worked before, just don't know what did change



On 14-04-18 01:43, Mihai Moldovan wrote:
* On 04/13/2018 01:54 PM, Bas van den Heuvel wrote:
In the past, I edited /usr/bin/x2gostartagent and removed the "-nolisten
tcp" part, and edited /etc/x2go/x2goagent.options to remove "-nolisten
tcp"

It's not working, even a simple xeyes docker fails to open display:

vdheuvel@arthur:/data/home/vdheuvel$ docker run   --rm -it
--net=host   -e DISPLAY  -v $HOME/.Xauthority:/root/.Xauthority
fr3nd/xeyes
No protocol specified
Error: Can't open display: :50.0
Makes sense, since it sounds like the UNIX socket is not passed through to
the
container.

I'm not sure why your TCP workaround worked in the past, though. The
DISPLAY
syntax should be local-socket-specific (either UNIX socket or abstract
UNIX
socket), without a fallback to TCP.

To use TCP connections, you'd have to specify DISPLAY=localhost:50.


The more curious thing here is that normally Xlib tries to connect via an
abstract UNIX socket, which theoretically should be also available in a
container - unless docker prohibits that, which would be plausible for
security
reasons.



Mihai

_______________________________________________
x2go-user mailing list
x2go-user@lists.x2go.org
https://lists.x2go.org/listinfo/x2go-user

_______________________________________________
x2go-user mailing list
x2go-user@lists.x2go.org
https://lists.x2go.org/listinfo/x2go-user

Reply via email to