Bingo !!! Thanks Михайло.

That's it. Disabling ProxyCommand in /etc/ssh/ssh_config allows me
to get a remote session.

The FreeIPA installation puts these lines in /etc/ssh/ssh_config

    GlobalKnownHostsFile /var/lib/sss/pubconf/known_hosts
    PubkeyAuthentication yes
    ProxyCommand /usr/bin/sss_ssh_knownhostsproxy -p %p %h

Just disabling ProxyCommand is enough.

Of course it is not nice that you get a core dump when ProxyCommand
is present. That's a bug for sure (in x2go and/or in
-- Kees

On 10-10-19 21:36, Михайло Падалка wrote:

AFAIK FreeIPA modifies client SSH config when joining domain, particularly sets 
ProxyCommand (to pull SSH fingerprints from server), and maybe some other 

Maybe that changes are causing problem with X2GO.

Ср, 9 жовт. 2019, 10:21 користувач Kees Bakker < 
<>> пише:

    On 08-10-19 14:17, Stefan Baur wrote:
    > Am 08.10.19 um 13:57 schrieb Kees Bakker:
    >> I already tried that with another system.
    >> Same result: core dumped.
    > In that case, I would like to ask you to do fresh installs of Ubuntu
    > 18.04 with X2GoServer and X2GoClient somewhere (say, two virtual
    > machines), that aren't joined to your FreeIPA environment.  Just two
    > plain and simple basic installations.  If it works there, then it's
    > likely to be an issue with your particular setup.
    Two virtual machines (with a reasonable fresh install) don't
    give the problem. I haven't completed the whole test because I
    needed to install LXDE, or MATE.
    Most important conclusion is that the connection worked well.
    No segfault.

    > Also, did you try if using a different session type makes a difference?
    > Say, a Desktop session of XFCE or MATE, or a single application
    > LibreOffice session, ...
    > Given your error message, it seems unlikely, but it's a quick check
    > compared to the effort two new installs require.

    I tried various desktops, all gave the "core dumped" message.

    Can we draw the conclusion that it is the SSH connection?
    How can I investigate this further? One thing I already tried was
    to run the remote sshd in debug. I noticed that it uses different
    connection methods between normal ssh and x2go.
-- Kees
    x2go-user mailing list <>

x2go-user mailing list

x2go-user mailing list

Reply via email to