I stood up some test machines to figure out the issue.  I have the issue on a 
clean RHEL7 machine with lots of packages and some security hardening done on 
it.  It does not happen on an Ubuntu MATE install or on a RHEL7 minimal install 
without hardening.  I need to track down the issue to see if it is something 
that might be able to be fixed.  I tried simple things like reverting the 
sshd_config and setting selinux to permissive.  While running with --debug and 
--libssd-debug, there is nothing obvious.  With --debug, the last statement is 
a mention that the ssh port is 22 (right before it calls ssh_connect, I think). 
 With --debug and --libssh-debug, the last statement seems like what I would 
consider benign ssh message passing.  There is really not much of interest.  
The only warning that I see at all is that /etc/ssh/ssh_known_hosts doesn't 

Does anyone have any ideas of what I should look at?  It has to be something 
that changed in over, since the latter still functions OK.


On Monday, March 2, 2020, 4:31:46 PM EST, Josh G <gabmaster...@yahoo.com> 

I just installed the Windows client version  It crashes as soon as it 
tries to make the SSH connection.  I tried debug and the debug window closes 
immediately as well.  Is there a log somewhere?  It was tried on two different 
machines that have different OSs and virus protection. works fine.  It 
doesn't crash when attempting to connect to a computer that isn't running SSH 
(just times out).  It does crash when trying to connect to that same computer 
by tunneling through another machine that is running SSH.  If I try to connect 
to a new machine, it crashes as soon as I accept the host key.  If you put in a 
wrong password, it still crashes.  Thus, there is never a completed SSH 
connection.  Is there anything I can look at or do?  I was hoping that 
would fix some of the annoyances that prevents me from deploying X2Go to other 
x2go-user mailing list

Reply via email to