Hi, dbus interface name should be Thumbnailer instead of thumbnailer to follow the naming conventions recommended in the dbus spec,
<arg type="u" name="handle" direction="out" /> integer handles are almost always wrong in dbus; using an object path is probably more correct. A good pattern is to use a mktemp-style random string in the object path, to avoid ever having 'recycling' problems, even if a process restarts. The returned object from Queue can have an interface like ThumbnailJob and have a method Unqueue, for example. <interface name="org.freedesktop.thumbnailer.manager"> is thumbnailer a namespace or an interface? Should probably be org.freedesktop.ThumbnailManager Havoc _______________________________________________ xdg mailing list [email protected] http://lists.freedesktop.org/mailman/listinfo/xdg
