On 19.03.2025 00:36, dm...@proton.me wrote: > Rename max_init_domid to domid_top to align with its usage in the code > (Arm), where it represents the upper boundary of the non-system domain > ID range.
I think I said before that I don't share this view of yours. The variable is quite appropriately named; it's the further use you made of it in earlier versions of work of yours in this area where the name ended up no longer reflecting the purpose. Yet that's not a reason to change the name. I'm unconvinced we actually need a variable tracking the largest known non-system domain ID. The domain list is sorted, so obtaining that ID should be reasonably easy and cheap without such a variable. Furthermore such a variable would likely also need reducing when the domain with the highest ID dies. > --- a/xen/drivers/char/console.c > +++ b/xen/drivers/char/console.c > @@ -472,7 +472,7 @@ static void cf_check dump_console_ring_key(unsigned char > key) > */ > static unsigned int __read_mostly console_rx = 0; > > -#define max_console_rx (max_init_domid + 1) > +#define max_console_rx (domid_top + 1) This use in particular is bogus. The intention here is to permit console access only to (some?) domains created during boot. Making a (conceptual) change here would require separate justification. Jan